XADM: Unable to Enable Advanced Security on User Account (152498)



The information in this article applies to:

  • Microsoft Exchange Server 4.0

This article was previously published under Q152498

SYMPTOMS

When you try to enable Advanced Security on a user mailbox within the Microsoft Exchange Administrator program, you may get the following error message:
The advanced security operation failed due to an unknown cause. Restart the Administrator program or the Key Management server, or both, and then try again.

Microsoft Exchange Administrator
ID no: c1031252

CAUSE

This problem can occur if a comma was used in the directory name for the user mailbox object.

WORKAROUND

To check, run the Microsoft Exchange Administrator program and check the properties for the user's mailbox. Then click the Advanced tab and look the Directory Name.

Currently there is no way to modify the Exchange X.500 database, so the user account will need to be deleted and recreated to fix the problem. Move the user's mail to a .PST file. Delete and recreated the user's mailbox, then import the .PST file back onto the server store.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 4.0. This problem was corrected in Microsoft Exchange Server version 5.0.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbbug kbenv kbnofix KB152498