SMS: Expired Systems Management Server Jobs Alter Detailed Job Status (152229)
The information in this article applies to:
- Microsoft Systems Management Server 1.0
- Microsoft Systems Management Server 1.1
This article was previously published under Q152229 SYMPTOMS
Displaying the detailed job status of a Systems Management Server job shows
Retrying or Canceled for Workstation entries after a Package Command
Manager (PCM) job has expired.
CAUSE
The Systems Management Server despooler incorrectly creates a detailed job
status MIF as the result of a PCM job expiry notification received from an
Systems Management Server client. In Systems Management Server 1.0, the
detailed job status for the Workstation entry is set to Retrying as the
result of the job expiry. In Systems Management Server 1.1, the detailed
job status for the Workstation entry is set to Canceled.
The expected behavior is to maintain the last reported job status for the
workstation.
RESOLUTION
Unfortunately the behavior of the despooler component under Systems
Management Server versions 1.0 and 1.1 cannot be resolved. The problem is
corrected in Systems Management Server version 1.2.
The following workarounds are suggested if you encounter problems
determining the current status of package installation for SMS clients.
- Extend the job expiration date to give enough time to review the job
status for each client, where possible.
- Use a NOIDMIF to report details about the package installation (that is,
Complete, Failed), so that a new attribute for the package is displayed
for each client detailing the install status.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Systems
Management Server versions 1.0 and 1.1. We are researching this problem and
will post new information here in the Microsoft Knowledge Base as it
becomes available.
The problem is corrected in Systems Management Server version 1.2.
Modification Type: | Minor | Last Reviewed: | 6/14/2005 |
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Keywords: | kbbug kbDespooler kbnetwork kbPCM kbpending KB152229 |
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