Error Printing to LPT1 with 1-2-3 Print Macro in Windows (152217)



The information in this article applies to:

  • Microsoft Excel 97 for Windows
  • Microsoft Excel for Windows 95
  • Microsoft Excel for Windows 5.0

This article was previously published under Q152217

SYMPTOMS

When you run a Lotus 1-2-3 print macro in Microsoft Excel, you may receive the following error message
Macro error at cell: <cell address>
where <cell address> is the address of the macro's print statement. After you click OK, you receive the following error message:
Error printing to LPT1

CAUSE

The reason for the error is that the macro is trying to create a file called "c:\lpt1" and the printer was not set up for printing from MS-DOS- based programs. If, when installing the printer driver, you clicked "No" to "Do you print from MS-DOS-based programs?", then Microsoft Windows 95 is using named pipes, and the port is not truly redirected as the Microsoft Excel macro thinks it is.

NOTE: The error also occurs when Microsoft Excel version 5.x is running on Microsoft Windows for Workgroups, version 3.11 and the port, LPT1, is not connected to a printer.

RESOLUTION

For the Lotus 1-2-3 print macros to work correctly, set up the printer to print from MS-DOS-based programs. To do so, follow these steps:

  1. Click Start, point to Settings, and then click Printers.
  2. Double-click the Add Printer icon.
  3. Click Next. Click Network Printer, and then click Next.
  4. Type the network path or the queue name of your printer. If you don't know its name, click Browse to view available network printers.
  5. Click Yes when asked "Do you print from MS-DOS-based programs?" Click Next.
  6. Click the Capture Printer Port button. Change the Device to LPT1 and click OK.
  7. Click Next.
  8. Continue to click Next until the printer is installed.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.

MORE INFORMATION



Lotus 1-2-3 is manufactured by a Lotus Development Corporation, a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding this product's performance or reliability.

Modification Type:MinorLast Reviewed:8/17/2005
Keywords:kb3rdparty kberrmsg kbprint KB152217