Unable to Install Office on Personal Netware 1.0 (151270)



The information in this article applies to:

  • Microsoft Office for Windows 4.2
  • Microsoft Office for Windows 4.3
  • Microsoft Office for Windows 95
  • Microsoft Office for Windows 95 7.0b

This article was previously published under Q151270
WARNING: The information in this article has not been confirmed or tested by Microsoft. Some or all of the information in this article has been taken from unconfirmed customer reports. ANY USE BY YOU OF THE INFORMATION PROVIDED IN THIS ARTICLE IS AT YOUR OWN RISK. Microsoft provides this information "as is" without warranty of any kind, either express or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.**

SYMPTOMS

When you run an administrative network installation of Microsoft Office (setup /a) on a Personal Netware server, the installation fails at the end with the following message:
Cannot change properties of the file named : R:\msoffice\setup.ini.
It is in use by another application.
Your choices are retry or cancel.

The same installation on the Netware server will finish successfully.

CAUSE

The Setup.ini file is a read-only file stored on the installation disk. During installation the file is copied to the server's hard disk as a read-only file. Office opens and closes this file many times during the installation process. In all cases, except for the very end of the installation, the file is opened as (Deny Write, Read). At the very end of the installation, the file is opened with desired access of (Deny Write, Deny Read, Write). These access rights are being expressed as NCP equivalent to the MS-DOS call being made. At this point, the Personal Netware server is returning a reply of Lock fail.

WORKAROUND

Install the administration copy to a substituted drive letter on the Server without the network loaded. When asked for a server name enter the following:

\\SERVER_NAME\VOLUME_NAME

If you want the Server computer to be a client also, do the following:

  1. Restart the computer, and this time load the network.
  2. Map the same drive letter that had been previously substituted.
  3. From Windows, run Setup.exe from the MSOFFICE subdirectory on the mapped drive.
  4. Do a workstation installation.
Repeat these 4 steps for each client computer.

REFERENCES

Novell network Support Encyclopedia, Document ID TID021675 and TID800174.

For additional information, please see the following article in the Microsoft Knowledge Base:

112587 Setup Error Message "Cannot Change Properties of <Filename>"


Modification Type:MinorLast Reviewed:8/17/2005
Keywords:KB151270