Works 3.0: Error Messages Starting Applets Under Windows 95 (150486)



The information in this article applies to:

  • Microsoft Works 3.0
  • Microsoft Works 3.0a
  • Microsoft Works 3.0b

This article was previously published under Q150486

SYMPTOMS

If you use Works 3.0 in Windows 95, you may receive one of the following error messages when you try to insert an object from a shared application, such as WordArt, ClipArt, or Draw.
Source application not available: try reinstalling.

The object you tried to open was created with an application no longer available to Works or is not properly installed. Reinstall the source application.

-or-

Cannot start source document application.

You tried to use an application to edit or create an object, but Works could not start it for unknown reasons.

CAUSE

These error messages can be caused by missing or corrupt program files, or by corruption or invalid data in the Windows 95 system registry.

RESOLUTION

Missing or corrupt program files can be remedied by reinstalling Works.

If you are experiencing this error with a network installation of Works, information in the *.reg files may be incorrect; read the "Verify the Path to the Shared Application" section before re-registering or reinstalling the shared applications.

If reinstalling Works does not fix the problem, do the following.

Re-Register the Shared Application

NOTE: Do not follow these steps if you are using Works 4.x. To re-register shared applications with Works 4.x, see the following article in the Microsoft Knowledge Base:

150175 Works 95: How to Correctly Re-Register Shared Applications

The following instructions refer only to Works 3.0 running under Windows 95.

  1. Close all programs.
  2. Click the Start button, point to Find, and then click Files or Folders.
  3. In the Find dialog box, enter the name of the shared application registration file that is causing the problem.
       For this shared application:          type the following:
       ----------------------------          -------------------
       ClipArt Gallery                        Artgalry.reg
       Draw                                   Msdraw.reg
       Note-It                                Note-it.reg
       WordArt                                Wordart2.reg
    					
  4. Click Find Now.

    When the search is complete, you will see the file listed in the Find window. If the file is not found, skip to the section titled, Remove and Reinstall the Shared Application.
  5. Double-click the file name. You will receive a message that the file has been successfully registered. Click OK.
  6. Close the Find box.
  7. Start Works and try to insert the object.
If you still receive the error listed at the top of this article, continue with the following section.

Remove and Reinstall the Shared Application

To remove and reinstall the shared application, do the following:

  1. Click the Start button, point to Programs, then point to Microsoft Works, then click Microsoft Works Setup.
  2. Click Add/Remove.
  3. Click Accessories, then click Change Option.
  4. Clear the check the box for the shared application producing the error.
  5. Click OK, then click Continue.
  6. Click Yes to remove the component, then click Remove.
  7. Click OK to complete the setup.
  8. Follow steps 1 through 7 again. In step 4, place a check in the box to reinstall the shared application.

Verify the Path to the Shared Application

If you have a network installation of Works, before re-registering or reinstalling the shared applications, verify the pathing to the shared applications is correct. To view or editing the pathing to the shared applications do the following:

  1. Open Msworks3.reg in Wordpad. This file is located in the Windows folder, not the Works folder.
  2. On the Edit menu, click Replace.
  3. Replace all instances of C:\MSWORKS\MSWORKS.EXE with <path>\MSWORKS.EXE, where <path> represents the drive letter and folder where Works is installed.
  4. Save the file, making sure to specify TEXT as the format.
If you still receive the error listed at the top of this article, re- register the shared applications and Msworks3.reg following the steps in the, Re-Register the Shared Applications, section.

MORE INFORMATION

When you run Works under Windows 3.1, the *.reg file information is merged into the Windows Reg.dat file. When you install Windows 95, the *.reg files and Reg.dat are merged into the System Registry.

If you receive an error message when inserting objects other than the ones listed in this article, determine which program installs the shared application and then contact the manufacturer.

Modification Type:MajorLast Reviewed:9/25/2003
Keywords:kbenv kbprb kbsetup KB150486