How to Troubleshoot Windows Protection Error Messages (149962)



The information in this article applies to:

  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98
  • Microsoft Windows 95

This article was previously published under Q149962
If this article does not describe the error message that you are receiving, view the following Microsoft Knowledge Base article to view more articles that describe error messages:

315854 Windows 98 and Windows Me Error Message Resource Center

SYMPTOMS

When you start Windows, you may receive one of the following error messages, where device name is a device name:
While initializing device device name Windows Protection Error

-or-

Windows Protection Error
When you shut down your computer, you may receive the following error message:
Windows Protection Error
NOTE: To more effectively search the Microsoft Knowledge Base, use keywords that relate to your issue. If you are searching for troubleshooting information that is not mentioned in this article, search the Microsoft Knowledge Base again by using keywords that are listed in the following Microsoft Knowledge Base article:

242450 How to Query the Microsoft Knowledge Base Using Keywords

CAUSE

This behavior can occur when a when your computer loads or unloads a virtual device driver (VxD). In many cases, the VxD that did not load or unload is mentioned in the error message. In other cases, you may not be able to determine which VxD caused the behavior.

Windows Protection error messages can occur under any of the following conditions:
  • If a real-mode driver and a protected-mode driver are in conflict.
  • If the registry is damaged.
  • If either the Win.com file or the Command.com file are infected with a virus, or if either of the files are damaged.
  • If a protected-mode driver is loaded from the System.ini file and the driver is already initialized.
  • If there is a physical input/output (I/O) address conflict or a random access memory (RAM) address conflict.
  • If there are incorrect complementary metal oxide semiconductor (CMOS) settings for a built-in peripheral device (such as cache settings, CPU timing, hard disks, and so on).
  • If the Plug and Play feature of the computer's basic input/output system (BIOS) is not working correctly.
  • If the computer contains a malfunctioning cache or malfunctioning memory.
  • If the computer's motherboard is not working properly.
  • If you installed Microsoft Office 97 and you are using the Novell Client 32 software.

RESOLUTION

To resolve a Windows Protection error message:
  1. Start your computer in Safe mode. For information about how to start your computer in Safe mode, view one of the following sections, depending on your operating system.

    Windows 95

    To start Windows 95 in Safe mode, press the F8 key when you see the "Starting Windows 95" message, and then choose Safe Mode from the Startup menu.

    Windows 98 and Windows 98 Second Edition

    To start Windows 98 in Safe mode, restart your computer, press and hold down the CTRL key until the Windows 98 Startup menu appears, and then choose Safe Mode.

    Windows Millennium Edition (Me)

    To start Windows Me in Safe mode, press and hold down the CTRL key while you restart your computer, and then choose Safe Mode on the Windows Me Startup menu.

  2. If you do not receive the error message when you start your computer in Safe mode or when you shut down your computer from Safe mode, view one of the following articles in the Microsoft Knowledge Base: Windows 95:

    136337 Troubleshooting Windows 95 Startup Problems

    145926 How to Troubleshoot Windows 95 Shutdown Problems

    Windows 98:

    188867 Troubleshooting Windows 98 Startup Problems

    202633 How to Troubleshoot Windows 98 Shutdown Problems

    Windows Millennium Edition (Me):

    273738 TITLE: Troubleshooting Windows Me Startup Problems

    273746 TITLE: How to Troubleshoot Windows Me Shutdown Problems

  3. If you receive the error message when you attempt to start the computer in Safe Mode, follow the steps listed below to restore the registry:
    1. Boot the computer from an Emergency Boot Disk (EBD). If you do not have an EBD, view one of the following articles in the Microsoft Knowledge Base:

      267287 How to Create a Startup Disk in Windows Millennium Edition

      NOTE: The previous article also applies to Windows 98.

      284943 How to Create a Windows 95 Startup Disk in MS-DOS

      187632 How to create a Windows 98 startup disk that supports FAT32

    2. Follow the steps in the following articles that corresponds to your Operating System.

      221512 How to Manually Restore the Windows 98/Me Registry

      132332 How to back up the Registry (Windows 95)

  4. If your computer is a Plug and Play computer, reinstall Windows by using the setup /p I command.For additional information about how to install Windows 95, click the article number below to view the article in the Microsoft Knowledge Base:

    129260 Windows 95 Setup: Description and Troubleshooting Steps

  5. If you are using the Novell Client 32 software, remove it, and then install Microsoft Client for Novell Networks.
  6. Verify that the computer's CMOS settings are correct. For information about how to change CMOS settings on your computer, view the computer's documentation or contact the computer manufacturer.
  7. Install a "clean" copy of Windows in an empty folder. For further information, please see one of the following articles below:

277648 How to Install Windows Millennium Edition in a New Folder

193902 How to Install Windows 98 Into a New Folder

142096 How to Reinstall Windows 95 to a New Folder

IMPORTANT: If the error message still occurs, it is most likely caused by faulty hardware.

MORE INFORMATION

The VxD that is generating the error message can be any VxD, either a default VxD that is installed, or a third-party .386 driver that is loaded from the System.ini file. If you do not know which driver is causing the error message, create a Bootlog.txt file, and then check to see which driver is the last driver that is initialized. This is typically the driver that is causing the problem.

NOTE: You may also receive a Windows Protection error message when you restart Windows 95 after you install a program or make a configuration change to your computer. For additional information about this issue, click the article number below to view the article in the Microsoft Knowledge Base:

157924 Err Msg: "IOS Failed to Initialize" on Boot

For additional information about how to resolve Windows protection issues, click the article number below to view the article in the Microsoft Knowledge Base:

131431 How to Troubleshoot Registry Errors in Windows 95


Modification Type:MinorLast Reviewed:12/16/2004
Keywords:kbDiskMemory kberrmsg kbprb kbProd2Web kbtshoot KB149962