PUB: Can't Load Speller or Dictionary (149120)
The information in this article applies to:
- Microsoft Publisher for Windows 3.0
This article was previously published under Q149120 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you attempt to run the Spell Checker, you may receive the following
error message:
Publisher cannot load the speller or dictionary to install
the Spell Checker and Hyphenation. For more information on
running Setup, press F1 now.
If you click OK, the Spell Checker continues to check spelling in the
publication.
CAUSE
This problem may occur for either of the following reasons:
- The Custom.dic file has become corrupted.
-or-
- The registry key for custom dictionaries is incorrect or is missing.
RESOLUTION
To resolve this problem, use either of the following methods.
Method 1: Corrupted Custom.dic File- Open Custom.dic in a text editor such as WordPad. By default, this file is in the following folder:
C:\Program Files\Common Files\Microsoft Shared\Proof
NOTE: This file can be located elsewhere. If it is not in the
folder previously listed, use the Windows 95 Find File feature to
locate it.
- Copy and paste the words to a text frame in Publisher.
- Close the text editor, and rename Custom.dic.
- In Publisher, click Check Spelling on the Tools menu.
NOTE: Add is available. Use Add to add the
words into the new Custom.dic.
Method 2: Incorrect or Missing Registry KeyWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
If you suspect that the problem is related to incorrect registry
settings, use the following steps to edit the registry.
- Open HKEY_LOCAL_MACHINE\Software\Microsoft\Shared
Tools\Proofing Tools\Custom Dictionaries.
- Export the Custom Dictionaries key.
NOTE: If the key is missing, skip to step 4.
- Delete the Custom Dictionaries key.
- On the Windows Start menu, point to Settings, and click Control Panel. Double-click the Add/Remove Programs icon, and run Publisher Setup.
- Select the option to reinstall the program.
This will force the re-registration of the custom Dictionaries
key.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article. This problem was corrected in
Microsoft Publisher 98.
Modification Type: | Minor | Last Reviewed: | 8/17/2005 |
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Keywords: | kberrmsg kbprb kbproof kbsetup KB149120 |
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