Page Fault in KERNEL32.DLL When You Open or Create a Document (146059)
The information in this article applies to:
- Microsoft Office for Windows 95
- Microsoft Word for Windows 95
This article was previously published under Q146059 SYMPTOMS
When you use the Office Shortcut Bar or the Start menu to open or to create
a Word document, you receive the following message:
This program has performed an illegal operation and will be shut down.
If the problem persists, contact the program vendor.
If you click Details, you receive an error message similar to the
following:
MSOW caused an invalid page fault in module KERNEL32.DLL at
0137:bff782ae.
CAUSE
This problem occurs when you do either of the following:
- You click Open Office Document or New Office Document on the Start menu,
and you then select a Word document.
-or-
- You click Open A Document or Start A New Document on the Office Shortcut
Bar, and you create a new Word document.
This behavior occurs after you install any program that inserts a complex
DDEExec command in the following entries in the registry:
HKEY_LOCAL_MACHINE\Software\Classes\Word.Backup\Shell\Open\DDEEXEC
-or-
HKEY_LOCAL_MACHINE\Software\Classes\Word.Backup\Shell\New\DDEEXEC
Several programs, including the Microsoft Macro Virus Protection tool (also
called the Scanprot template), modify the DDEEXEC entry in the registry.
RESOLUTION
To correct the problem that occurs when you use the Start menu or the
Office Shortcut Bar to open a document or to create a new document, do the
following:
- Open Windows Explorer. Locate and double-click the Winword7.reg file to
re-register Word.
- Start Word.
- Click Open A Document or Start A New Document on the Office Shortcut
Bar. This resets the application settings in the Office Shortcut Bar.
- Close Word.
You can now choose Open A Document or Start A New Document on the Office
Shortcut Bar.
WORKAROUND
You can work around the problem that occurs when you use the Start menu or
the Office Shortcut Bar to open a document; however, no workaround exists
for when you create a new Word document. Instead you must create a new Word
document from within Word.
To create a new Word document, do the following:
- Start Word.
- On the File menu, click New, and then double-click a template.
To work around the problem that occurs when you open a document, use the
following steps:
- Click the Start button, point to Programs, and then click Windows
Explorer.
- On the View menu, click Options, and then click the File Types tab.
- Under Registered File Types, click Microsoft Word Document, and then
click Edit.
- In the Edit File Type dialog box under Actions, click Open, and then
click Edit.
- Delete the complex command in the DDE Message box and type the following
text:
- Click OK.
- Click Close, and then click Close again to close the Options dialog
box.
NOTE: Word may not run when you open a Word document after you use this
workaround, and the following message may appear:
Word cannot open the document. (<Folder Location>)
If you click OK, the following message appears:
The document name or path is not valid. (<Folder Location><Document
Name>).
If you click OK again, the document opens successfully.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Office for
Windows 95, version 7.0. This problem was corrected in Microsoft Office for
Windows 95, version 7.0b.
Modification Type: | Minor | Last Reviewed: | 8/17/2005 |
---|
Keywords: | KB146059 |
---|
|