Office: Setup Error: Please Insert Disk <Diamond><Smiley Face> (145760)
The information in this article applies to:
- Microsoft Office 97 for Windows
- Microsoft Office for Windows 95
This article was previously published under Q145760 SYMPTOMS
When you run the Microsoft Office Setup program from Distribution Media
Format (DMF) floppy disks in protected mode on certain laptop computers,
the computer may fail to read the disk in the floppy disk drive, or fail
to read the cabinet file on the disk.
If you then restart Microsoft Windows 95 in safe mode and run the Setup
program again, a blue screen may appear with the following message:
Error reading disk in drive a:
Please insert disk <Diamond Symbol><Smiley Face symbol> <Serial
Number> in drive a:
NOTE: Serial Number refers to the serial number of the disk, for example,
C0FD-FE9C or C0FE-E2B0.
CAUSE
This problem occurs because Windows is unable to read the floppy disk
drive in protected or real mode.
Windows 95 may be unable to read the floppy disk drive in protected mode
on certain Toshiba laptop computers that run the upgrade version of
Windows 95. This problem has also been observed to occur on a Compaq
Contura Aero 433c laptop.
When you restart Windows in safe mode, Windows is still unable to read
the floppy disk drive. This behavior may occur when you do the following:
- You click Shut Down on the Start menu, click Restart The Computer,
and click Yes.
-and-
- You press F5 when you see the message "Starting Windows 95."
-and-
- You run the Microsoft Office Setup program.
This problem is caused by a memory leak in Voltrack.vxd.
NOTE: The problem may also occur in other computer models if you run the
Windows 95 Setup program, choose the Portable option, and then run the
Office Setup program.
RESOLUTION
To resolve this problem, obtain an updated Hsflop.pdr file. The updated
Hsflop.pdr file will allow you to successfully run Office Setup in
protected mode. The updated Hsflop.pdr file is version 4.00.951 (9/29/95)
or later. This file is available as a self-extracting, compressed file,
Hsflop.exe, from Toshiba Technical Support, Toshiba's BBS, and Toshiba's
World Wide Web site, www.toshiba.com.
NOTE: Although the memory leak has been fixed in future versions of the
Voltrack.vxd file, the file will only be available to customers in future
versions of Windows 95. The updated Voltrack.vxd file is not available
separately.
MORE INFORMATION
When you run Setup in protected mode on certain Toshiba laptop computers
that run the upgrade version of Windows 95, Windows 95 may not be able to
read data from the floppy disk drive. The behavior is due to a timing
problem in the protected mode floppy controller driver, Hsflop.pdr, that
is included in the upgrade version of Windows 95. The problem does not
occur with the pre-installed version of Windows 95 from Toshiba. The
Hsflop.pdr file is included with the Toshiba version of Windows 95.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Windows 95. We
are researching this problem and will post new information here in the
Microsoft Knowledge Base as it becomes available.
Modification Type: | Minor | Last Reviewed: | 8/17/2005 |
---|
Keywords: | kbbug kbenv kbsetup KB145760 |
---|
|