Windows NT 4.0 Explorer Cannot Administer Remote Shares (145579)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q145579

SYMPTOMS

In Windows NT 3.x it was possible, using File Manager, to view, create, edit and delete shares on a remote Windows NT computer, provided you had sufficient privileges. This facility is not available by default from Windows NT Explorer in Windows NT 4.0.

CAUSE

This is by design. Windows NT Explorer was designed as a browsing tool with limited administrative functionality.

RESOLUTION

You may use any or all of the following resolutions:

Use File Manager Included with Windows NT 4.0

A Windows NT 4.0 version of File Manager is included in Windows NT 4.0 and can be used to view, create, delete, or change share permissions on shares that are not local to the computer in the same way this was done in earlier versions of Windows NT.

Install the ShareUI Utility from the Windows NT 4.0 Resource Kit

To get the equivalent functionality with Windows NT Explorer, you must install a utility from the Windows NT 4.0 Resource Kit. After installing the Resource Kit, locate the directory to which you installed it, right- click the file named Shareui.inf and select Install. You may now view, create, edit, and delete shares on remote computers using the following steps:
  1. Click Start, Run, and type on the Run line the UNC name of the server you wish to administer, as in the following example: \\<servername>
  2. Click OK, and you should now see a folder called Shared Directories.
  3. Double-click this folder and it will show you any existing shares on the remote computer. You can right-click this window and select New, and then select Share to create a new share, or right-click on an existing share to Delete, Rename, or change permissions (through the share Properties) on that share.
NOTE: When you attempt to use the ShareUI utility when Internet Explorer 4.01 is installed, you may receive the following Dr. Watson error message:
An application error has occurred and an application error log is being generated.

Explorer.exe
Exception: access violation(0xC0000005), Address: <address>


For information about how to resolve this error message, please see the following article in the Microsoft Knowledge Base:

ARTICLE-ID: 185011
TITLE : Application Error Using ShareUI Tool

Administrative Wizard on Windows NT 4.0 Server

Another possible workaround on Windows NT Server is to use the Administrative Wizard, "Managing File and Folder Access."

To run this wizard, click Start, Programs, Administrative Tools, Administrative Wizards, and then click on "Managing File and Folder Access" and follow the instructions. This option can also be run separately by running Shrpubw.exe located in the %SystemRoot%\System32 subdirectory.

MORE INFORMATION

For more information on the ShareUI utility, see the Windows NT 4.0 Resource Kit Help file for information on shareui.

Modification Type:MajorLast Reviewed:5/7/2003
Keywords:kbenv kbhowto kbui KB145579