XCLN: Rule Moving Messages to Public Folder Does Not Work (143382)
The information in this article applies to:
- Microsoft Exchange Client 4.0
- Microsoft Exchange Client 5.0
- Microsoft Exchange Windows NT client 4.0
- Microsoft Exchange Windows NT client 5.0
- Microsoft Exchange Server 4.0
This article was previously published under Q143382 SYMPTOMS
When you define an Inbox Assistant rule to automatically move messages to a
public folder, this rule is not activated until you log in to a client.
CAUSE
This is by product design.
WORKAROUND
One workaround to the problem of not being able to automatically move
messages into public folders is to create a rule that will forward (instead
of move) the messages to the public folder. This rule will be performed
even when you are not logged in.
If the public folder is not listed in the Global Address List, the
Microsoft Exchange administrator must first complete the following steps in
the Microsoft Exchange Administrator program:
- Select the public folder and then get its properties by selecting the
Properties command on the File menu.
- Select the Advanced page. Clear the Hide From Address Book option.
This will make the folder appear in Global Address List.
- In the Microsoft Exchange client, create an Inbox Assistant rule to
forward messages to the public folder.
- After you create the rule, if the folder needs to be removed from the
Global Address List, check the Hide From Address Book option in the
Properties of the public folder in the Microsoft Exchange Administrator
program.
MORE INFORMATION
Any rule actions that move a message to a message store other than a user's
server-based mailbox store must be run on the client while the user is
logged in.
This is the case when moving messages to a local .PST file, as well as when
moving messages to a public folder. Public Folders may or may not reside on
the same server as a user's mailbox.
In order to move a message to a store, a user must be logged in to that
store with the proper permissions to post items. The rules engine (which
processes Inbox Assistant rules) cannot log in to another store (with the
necessary Windows NT privileges) as the user who created the rule. Instead,
it creates a Deferred Action message to tell the client to execute this
rule. When the client logs in to the server, the Deferred Action message is
sent to the client, which then performs the action specified in the rule.
Modification Type: | Minor | Last Reviewed: | 8/16/2005 |
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Keywords: | kbusage KB143382 |
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