ACC: "Couldn't Open Paradox.Net" Error Message (95/97) (142479)
The information in this article applies to:
- Microsoft Access for Windows 95 7.0
- Microsoft Access 97
This article was previously published under Q142479
IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, you should first make a backup copy of the
registry files (System.dat and User.dat). Both are hidden files in the
Windows folder.
SYMPTOMS
Advanced: Requires expert coding, interoperability, and multiuser skills.
When you try to use a Paradox file to import, export, or link data, you
may receive the following error message:
Couldn't open Paradox.net.
CAUSE
The Windows Registry has an incorrect setting for the ParadoxNetPath entry
or the ParadoxUserName entry. This can occur when you install Microsoft
Access into a folder other than \Msoffice\Access. These Registry entries
will be missing if the computer was not on a network when Microsoft Access
was installed.
RESOLUTION
You can modify the Paradox entries in the Windows Registry. To do so,
follow these steps.
WARNING: Modifications made to the system registry are considered advanced
usage of the Windows 95 or Windows NT operating systems. Extreme care
should be taken when making modifications. Any invalid or incorrect entries
may render the operating system unusable.
WARNING: Using Registry Editor incorrectly can cause serious problems that
may require you to reinstall Windows 95. Microsoft cannot guarantee that
problems resulting from the incorrect use of Registry Editor can be solved.
Use Registry Editor at your own risk.
For information about how to edit the registry, view the Changing Keys And
Values Help topic in Registry Editor (Regedit.exe). Note that you should
make a backup copy of the registry files (System.dat and User.dat) before
you edit the registry.
- Click the Start button, and then click Run.
- In the Open box, type regedit.
- Locate the HKEY_LOCAL_MACHINE registry folder.
- Expand the HKEY_LOCAL_MACHINE folder until you locate the
SOFTWARE\Microsoft\Jet\3.0\Engines\Paradox folder for Microsoft Access
7.0 or the SOFTWARE\Microsoft\Jet\3.5\Engines\Paradox folder for
Microsoft Access 97.
- Double-click the Paradox folder to view its contents.
- If no entry exists for ParadoxNetPath, click New on the Edit menu,
and then click String Value. Type ParadoxNetPath for the name of this
new string, and then press enter to save it.
- Select the ParadoxNetPath entry, and then on the Edit menu, click
Modify.
- In the Edit String box, type a valid path to the folder containing
the Paradox.Net file (for Paradox 3.x) or the Pdoxusrs.net file (for
Paradox 4.x), for example:
d:\PDOXDB
NOTE: If Paradox is not installed, then neither of the two files
(paradox.net or pdoxusrs.net) will exist on the machine. In
this case, change the ParadoxNetPath key's value to the
folder in which Msccess.exe is located.
NOTE: If more than one individual needs to connect to the same Paradox
Table, you must ensure that each user points to the same
ParadoxNetPath.
- Click OK to save the ParadoxNetPath setting.
- If no entry exists for ParadoxUserName, click New on the Edit menu,
and then click String Value. Type ParadoxUserName for the name of this
new string, and then press ENTER to save it.
- Select the ParadoxUserName entry, and then on the Edit menu, click
Modify.
- In the Edit String box, type a valid entry for the user name, for
example:
Microsoft Access
- Click OK to save the ParadoxUserName setting.
- Quit the Registry Editor, and then try again to import, export, or
link a Paradox file.
MORE INFORMATION
Paradox is manufactured by Borland International, Inc., a vendor
independent of Microsoft; we make no warranty, implied or otherwise,
regarding this product's performance or reliability.
REFERENCES
For more information about Registry setting accessing Paradox data, type
"Paradox" in the Office Assistant, click Search, and then click to view
"Customize Windows Registry Settings Used by Microsoft Access".
Modification Type: | Major | Last Reviewed: | 10/20/2003 |
---|
Keywords: | kb3rdparty kberrmsg kbprb KB142479 |
---|
|