Error Message: Error Loading C:\Windows\System\Setup.exe (142329)



The information in this article applies to:

  • Microsoft Windows 95

This article was previously published under Q142329
Important This article contains information that shows you how to help lower security settings or how to turn off security features on a computer. You can make these changes to work around a specific problem. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect your system.

SYMPTOMS

After you install or remove Norton Utilities for Windows 95, Norton AntiVirus for Windows 95, or Norton Navigator, you may receive the following error message when you restart Windows 95:
Error loading C:\Windows\System\Setup.exe.
You must reinstall Windows.

CAUSE

This error message can occur when Symantec's installation program cannot change the Windows 95 shell to Windows Explorer after installing or removing a program. Symantec Technical Support has confirmed that this problem occurs when a System.in_ file is present in the Windows folder.

RESOLUTION

Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

Note An antivirus program is designed to help protect your computer from viruses. You must not download or open files from sources that you do not trust, visit Web sites that you do not trust, or open e-mail attachments when your antivirus program is disabled.

For additional information about computer viruses, click the following article number to view the article in the Microsoft Knowledge Base:

129972Computer viruses: description, prevention, and recovery

Follow these steps to set Windows Explorer as the Windows 95 shell:
  1. Restart your computer. When you see the "Starting Windows 95" message, press the F8 key, and then choose Command Prompt Only.
  2. Use any text editor (such as Edit.com) to open the System.ini file in the Windows folder. To use Edit.com, type the following line:

    edit c:\windows\system.ini

  3. Change the line that reads

    Shell=C:\Windows\System\Setup.exe

    to:

    Shell=Explorer.exe

  4. Save the System.ini file and then close the editor.
  5. Restart your computer.
To prevent the problem from reoccurring, delete or rename the System.in_ file in the Windows folder.

MORE INFORMATION

The third-party products discussed in this article are manufactured by vendors independent of Microsoft; we make no warranty, implied or otherwise, regarding these products' performance or reliability.

Modification Type:MinorLast Reviewed:3/17/2005
Keywords:kbAppCompatibility KB142329