No Windows or Network Logon Dialog Box at Startup (141858)
The information in this article applies to:
- Microsoft Windows Millennium Edition
- Microsoft Windows 98 Second Edition
- Microsoft Windows 98
- Microsoft Windows 95
This article was previously published under Q141858 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you start Windows, you may not receive a Windows or a network
logon dialog box, or you may receive one of the following error messages:
No network provider accepted the given network path.
The operation being requested was not performed because the user has
not logged on to the network. The specified service does not exist.
Or, the Change Passwords tab may be missing from the Passwords Properties dialog box. Note that this symptom occurs only if the second cause listed below is in effect. In addition, if you are not prompted to log on and then you immediately log off, you will then receive a prompt to log on.
CAUSE
This behavior can occur if any of the following conditions exists:
- The Primary Network Logon setting is not set correctly.
- The following entry appears in the following registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Network\Real Mode Net
AutoLogon=xx NOTE: The AutoLogon value must be a BINARY value and must be set to 00 for automatic logon to work.
- : The AutoLogon value must be a BINARY value and must be set to 00 for automatic logon to work.You are logging on to a Novell NetWare network and the server you log
on to is running multiple frame types.
- : The AutoLogon value must be a BINARY value and must be set to 00 for automatic logon to work.You are logging on to a Microsoft or NetWare network and you have
cached your network password.
- : The AutoLogon value must be a BINARY value and must be set to 00 for automatic logon to work.The network adapter is improperly configured.
RESOLUTION
Use the troubleshooting steps that are listed below to resolve the problem. Make sure to restart Windows after each step and test to see if the problem is resolved.
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk. NOTE: You can edit the registry by using System Policy Editor (Poledit.exe) or Registry Editor (Regedit.exe). Check with your network administrator before you make any changes to the registry.
System Policy Editor (Poledit.exe) is available in the Admin\Apptools\Poledit folder on the Windows 95 CD-ROM. Use the Add/Remove Programs tool in Control Panel to install System Policy Editor.
In Windows 98, System Policy Editor is available in the
Tools\Reskit\Netadmin\Poledit folder on the Windows 98 CD-ROM.
NOTE: System Policy Editor is not included in the floppy disk version of Windows 95. You can download Policy.exe, a self-extracting
file that contains Poledit.exe, from online services. For additional information about downloading Policy.exe, click the article number below
to view the article in the Microsoft Knowledge Base:
135315 CD-ROM Extras for Microsoft Windows 95 Update
Troubleshooting Steps- Click Start, point to Settings, click Control Panel, and then double-click Network. Click the appropriate setting in the Primary Network Logon box, and then click OK.
- Delete the following entry in the following registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Network\Real Mode Net
AutoLogon=xx - Click Start, point to Settings, click Control Panel, and then double-click Network. Double-click IPX/SPX-Compatible Protocol, click the Advanced tab, click Frame Type, change the value from Auto to the specific frame type that is running on the server you log on to, click OK, and then click OK. If you do not know which frame type is running on the server you log on to,contact your network administrator.
Repeat this step as necessary, trying each frame type, to determine if
selecting one of the frame types causes a network logon dialog box
to appear at startup.
- Disable the Automatic NetWare Login option by using either System Policy Editor (as described on page 515 of the Microsoft Windows 95 Resource Kit), or by using Registry Editor to add the following DWORD value:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\NetworkProvider\DisableDefaultPasswords = 1
For additional information about troubleshooting problems related to enabling the Maximum Sockets or Maximum Connection setting, click the article number below
to view the article in the Microsoft Knowledge Base:
142489 Problems After Modifying Maximum Connections or Sockets Value
- This issue can also occur if the following setting is listed in the registry under the following registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Network
Disable Password Caching
Whether the value is set to 0 or 1, remove it to resolve this issue.
Modification Type: | Minor | Last Reviewed: | 12/16/2004 |
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Keywords: | kbnetwork kbprb kbWinME msnets win95 win98 win98se KB141858 |
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