Works 95: Errors Installing Works 4.0 from Compact Disc (141556)



The information in this article applies to:

  • Microsoft Works for Windows 95, version 4.0

This article was previously published under Q141556

SYMPTOMS

When you attempt to install Microsoft Works 4.0 for Windows 95 from the Works & Bookshelf compact disc, you may receive one of the following error messages:
ACMSETUP caused an invalid page fault in module MSSETUP.DLL

BOOTSTRAP performed an illegal operation in module LZEXPAND.DLL

System Error: Windows cannot read from drive D:

ACMSETUP caused an exception C000006H in module MSSETUP.DLL

CAUSE

These errors may occur if the CD-ROM drive is unable to access all files and folders on the compact disc. Due to physical read limitations of some CD-ROM drives, you may not be able to access some files and folders on the Works 4.0 & Bookshelf 95 compact disc. If the compact disc is dirty or scratched, you may also experience this problem.

RESOLUTION

Inspect and Clean the Compact Disc

To verify that the compact disc is clean and free of scratches, inspect the shiny side of the disc. Clean the disc by wiping it with a soft cloth in a straight line, starting from the center of the disc and working your way out to the edge. If there are no apparent scratches, and if the errors still occur after you clean the compact disc, use the steps in the following section to test for drive capacity limitations.

Testing Your CD-ROM Drive

To test for specific drive-capacity limitations, follow these steps:

  1. On the Start menu, point to Programs, and then click MS-DOS prompt.
  2. At the MS-DOS prompt, type md test and press ENTER.
  3. Type cd test and press ENTER.
  4. Type the following and press ENTER.

    copy d:\msworks\msworks.exe

    NOTE: Steps 4-6 assume that drive D is the drive letter of your CD-ROM drive.
  5. Type the following and press ENTER:

    copy d:\msworks\msworks.m14

  6. Type the following and press ENTER

    copy d:\msworks\Mmcat\Dibs5c\Strpopd.dib

    NOTE: This is the last file on the compact disc.
If you receive the following error message
CDR101: Not Ready
it indicates that the CD-ROM player cannot read the compact disc at the specified location. This is a physical limitation of the CD-ROM drive, and the problem will not be resolved by replacing the Works 4.0 & Bookshelf 95 compact disc.

If the files do copy, test the integrity of the files that have been copied from your CD-ROM drive to your hard disk drive using the MS-DOS File Compare program (Fc.exe). This test can be used to determine if the CD-ROM subsystem is functioning properly at the device driver and hardware levels.

The Fc.exe utility is a useful method for testing problems related to general protection (GP) faults or other critical errors (such as read errors or out of memory messages) that may occur when you run a CD-ROM program using Windows.

To test the copied files, use the Fc.exe with the /B (binary) switch. For example, to compare the Msworks.exe file on your compact disc with the Msworks.exe file on your hard disk, type the following at the MS-DOS command prompt and press ENTER:

fc /b d:\Msworks\Msworks.exe Msworks.exe

where your CD-ROM drive is drive D.

If you receive error messages, the CD-ROM drive is having problems reading the compact disc at that location.

Modification Type:MajorLast Reviewed:11/15/2004
Keywords:kbprb KB141556