"There is no license" error message starting Microsoft Access (141373)



The information in this article applies to:

  • Microsoft Access for Windows 95 7.0
  • Microsoft Access 97

This article was previously published under Q141373
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

Novice: Requires knowledge of the user interface on single-user computers.

SYMPTOMS

When you start Microsoft Access 97, you may receive one of the following error messages:
Microsoft Access can't start because there is no license for it on this machine.
Can't find the database you specified or you didn't specify a database at all.
When you start Microsoft Access 7.0, you may receive the following error message:
Microsoft Access can't be started as there is no license for it on this machine.

CAUSE

There are two possible causes for this error message.

The most likely cause is that Microsoft Access is not properly registered on your computer. If Microsoft Access is not properly registered on your computer, follow the steps in the "Rename a font, and then reinstall Microsoft Access" section of the "Resolution" section of this article to properly register Access on your computer.

The second cause applies only to computers that are running Microsoft Windows NT 4.0 or Microsoft Windows 2000. On these operating systems, you may also receive this error message if you do not have Read permissions to the Licenses key in the registry. If this applies to you, follow the steps in the "No Read Permissions to Licenses Key" section of the "Resolutions" section of this article to give necessary users and groups Read permissions to the Licenses key.

RESOLUTION

Note: If you are running Microsoft Windows 98, you can download a tool that corrects the problem that is discussed in this article. If you are running any operating system other than Windows 98, however, this tool may not work correctly.

For more information about downloading this tool, click the following article number to view the article in the Microsoft Knowledge Base:

191224 AcLicn97.exe available in Download Center

Rename a font, and then reinstall Microsoft Access

Important If you received an error message when you installed Access similar to
The configuration of the ODBC Microsoft driver name and extension driver failed.
and you then received one of the error messages that is mentioned in the "Symptoms" section of this article, install MDAC 2.8 or an earlier verion from the following Microsoft Web site:

To obtain MDAC 2.8, visit the following Microsoft Developer Network (MSDN) Web site: Note In the following steps, when you reinstall Microsoft Access 97 by using the Setup Maintenance Mode, you do not have to uninstall Microsoft Access first. This operation simply returns the computer to the installation state that it was in the last time that you ran Setup.

Follow these steps to correct the registry error.

Note Because there are several versions of Windows, the following steps may be different on your computer. If they are, please consult your product documentation to complete these steps. If you are running Microsoft Windows Millennium Edition, follow the steps in the "Steps for Microsoft Windows Millennium" section later in this article.
  1. Quit all Microsoft Office programs that may be running on your computer.
  2. On the Start menu, point to Find, and then click Files or Folders.
  3. In the Named box, type hatten.ttf.
  4. In the Look in box, type c:\windows\fonts.

    Note
    The path to the Fonts folder may be different on your computer.
  5. Click Find Now to start the search.

    Note If Hatten.ttf is not found, try searching for Haettenschweiler.ttf. Haettenschweiler is the full name of the Hatten font.
  6. Under Name, right-click the hatten.ttf file, and then click Rename on the shortcut menu that appears.
  7. Change the name of the file to hatten.xxx. If you receive a prompt that states that changing the extension may cause the file to become unusable, click Yes.
  8. Minimize, but do not close, the Find dialog box.
  9. On the Start Menu, point to Settings, and then click Control Panel.
  10. In Control Panel, double-click Add/Remove Programs.
  11. In the Add/Remove Program Properties dialog box, click the Install/Uninstall tab, and select Microsoft Office 97, Professional Edition in the program list.
  12. Click Add/Remove to run Office Setup in Maintenance Mode.
  13. In the Microsoft Office 97 Setup dialog box, click Reinstall.
  14. After the reinstallation is finished, click the Find dialog box on the taskbar to maximize it.
  15. Under Name, right-click the hatten.xxx file, and then click Rename on the shortcut menu that appears.
  16. Change the name of the file back to hatten.ttf.
Microsoft Access should now be properly registered.

Steps for Microsoft Windows Millennium Edition

Important If you received an error message when you installed Access similar to
The configuration of the ODBC Microsoft driver name and extension driver failed.
and you then received one of the error messages that is mentioned in the "Symptoms" section of this article, install MDAC 2.8 or earlier from the following Microsoft Web site:

You can obtain MDAC 2.8 from the following Microsoft Web site:
  1. Quit all Microsoft Office programs that may be running on your computer.
  2. Click Start, point to Programs, point to Accessories, and then click MS-DOS Prompt.
  3. At the MS-DOS prompt, type cd fonts, and then press ENTER.
  4. At the MS-DOS prompt, type ren hatten.ttf hatten.old, and then press ENTER.

    Note At this point, you may receive the following error message:
    duplicate file name or file in use.
    If this is true, follow these steps in lieu of steps 1 through 4 to rename the font:
    1. Restart the computer with the Startup disk in the floppy disk drive.
    2. Choose option 4 for a Minimal Boot at the Startup screen.
    3. At the MS-DOS prompt, type c:, and then press ENTER.
    4. At the MS-DOS prompt, type cd windows\fonts, and then press ENTER.
    5. At the MS-DOS prompt, type ren hatten.ttf hatten.old, and then press ENTER.
  5. Restart the computer.
  6. Click Start, point to Settings, and then click Control Panel.
  7. In Control Panel, double-click Add/Remove Programs.
  8. In the Add/Remove Program Properties dialog box, click the Install/Uninstall tab, and then click Microsoft Office 97, Professional Edition in the program list.
  9. Click Add/Remove to run Office Setup in Maintenance Mode.
  10. In the Microsoft Office 97 Setup dialog box, click Reinstall.
Microsoft Access should now be properly registered.

No Read permissions to licenses key

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Important The steps in this section apply only to computers that are running Microsoft Windows NT 4.0 or Microsoft Windows 2000.

When you are logged on as an administrator on a computer that is running Windows NT 4.0 or Windows 2000, you can use Registry Editor to check and to modify user permissions to the different registry keys.

To examine the user permissions, follow these steps:
  1. Log on to the problem computer as an Administrator.
  2. Click Start, click Run, type regedt32, and then click OK.
  3. Select the \\HKEY_CLASSES_ROOT\Licenses key.
  4. On the Security menu, click Permissions.
  5. Make sure that the necessary users and groups have at least Read permissions to the key.
  6. Close Registry Editor and restart the computer.
When you log on as a typical user, you should now be able to start Microsoft Access without problems.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For more information about how to install Access 97 and Access 2000 on the same computer, click the following article number to view the article in the Microsoft Knowledge Base:

241141 How to install Access 97 and Access 2000 on the same computer


Modification Type:MajorLast Reviewed:9/1/2006
Keywords:kbPubTypeKC kberrmsg kbprb kbsetup KB141373 kbAudDeveloper