ACC: Microsoft Access Can't Start the Data Access Object (141294)
The information in this article applies to:
- Microsoft Access for Windows 95 7.0
- Microsoft Access 97
This article was previously published under Q141294 Novice: Requires knowledge of the user interface on single-user computers.
SYMPTOMS
When you start Microsoft Access, you may receive the following
error message:
Microsoft Access can't start the data access object (DAO) and so
it can't continue.
You may also receive the following error message:
A system error occurred, or there isn't enough free memory to start
Microsoft Access. Close unneeded programs and try again.
CAUSE
You have mismatched dynamic-link library (.dll) files for the versions of
Microsoft Office and Microsoft Access installed on your computer.
RESOLUTION
To resolve the mismatched .dll files, do one of the following:
- Use the Regsvr32.exe file to reregister the .dll files.
- Uninstall and reinstall Microsoft Access.
Using the Regsvr32.exe File to Reregister Your .dll Files
Regsvr32.exe is an application that is used to register dynamic-link
libraries (DLLs) and ActiveX controls in the Windows registry. You can use this file to eliminate the issue of mismatched .dll files.
To re-register your .dll files using Regsvr32.exe do the following:
- Verify that the Regsvr32.exe file is in the sytem folder where Windows is installed.
- Click the Start button, and then click Run.
- In the Open or Run box, type the following:
Regsvr32 c:\progra~1\common~1\micros~1\dao\dao3032.dll
NOTE: An alternative method of registering DLLs is to use Windows
Explorer to find the DLL; then, double-click it, in the Open With
Box select Regsvr32.exe, and click OK. This creates a permanent
association of all DLLs with Regsvr32.exe. You can easily register
other unregistered DLLs by double-clicking them.
For information about how to obtain this file, please see the following
article in the Microsoft Knowledge Base:
161983 ACC: Regsv32a.exe Available in Download Center
Completely Uninstalling and Reinstalling Microsoft Access
To uninstall and reinstall Microsoft Access, do the following:
- Click the Start button, point to Settings, and then click Control Panel.
- In Control Panel, double-click Add/Remove Programs.
- In the Add/Remove Programs Properties dialog box, click to select
Microsoft Access, and then click Add/Remove or Add/Change.
- Follow the instructions to remove all of Microsoft Access.
NOTE: If you have installed Microsoft Access as a part of Microsoft
Office, you will need to remove Microsoft Office completely,
not just the Microsoft Access component, to solve the problem.
- Start Windows Explorer. On the View menu, click Options and make sure the Show All Files option box is selected.
- Verify that the following files have been removed from your computer.
For Microsoft Windows 95 or 98, the default paths and files are as follows (where <windir> is the folder where you have Windows installed):
Folder Location File Name
---------------------------------------------------------------
\Program Files\Common Files\Microsoft Shared\DAO DAO3032.DLL
\<windir>\System MSJETSQL.TLB
\<windir>\System MSJINT32.DLL
\<windir>\System MSJT3032.DLL
\<windir>\System MSJTER32.DLL
\<windir>\System MSRD2X32.DLL
\<windir>\System MSWNG300.DLL
\<windir>\System VAEN232.DLL
\<windir>\System VBA232.DLL
\<windir>\System VBAJET32.DLL
\<windir>\System VBAR2232.DLL
\<windir>\System VEN2232.OLB
For Microsoft Windows NT or Windows 2000, the paths and files are as follows (where <windir> is the folder where you have Windows installed):
Folder Location File Name
---------------------------------------------------------------
\<windir>\System32 DAO3032.DLL
\<windir>\System32 MSJETSQL.TLB
\<windir>\System32 MSJINT32.DLL
\<windir>\System32 MSJT3032.DLL
\<windir>\System32 MSJTER32.DLL
\<windir>\System32 MSRD2X32.DLL
\<windir>\System32 MSWNG300.DLL
\<windir>\System32 VAEN232.DLL
\<windir>\System32 VBA232.DLL
\<windir>\System32 VBAJET32.DLL
\<windir>\System32 VBAR2232.DLL
\<windir>\System32 VEN2232.OLB
NOTE: If any of these files have not been removed, you should delete them from your computer.
- Remove the DAO folder from your hard disk.
- Re-install Microsoft Access. To do so, follow these steps:
- Click the Start button, point to Settings, and then click Control
Panel.
- In Control Panel, double-click Add/Remove Programs.
- In the Add/Remove Programs Properties dialog box, click Install.
- Follow the instructions to install Microsoft Access on your
computer.
- Start Microsoft Access. If you again receive the error message
listed in the "Symptoms" section, reset the Windows Registry settings
for Microsoft Access. To do so, follow these steps:
- Click the Start button, and then click Run.
- Type a command to run the Microsoft Access Setup program using
the /y switch, for example:
a:\setup /y
- In the Installation Maintenance Program dialog box, click Re-install. The Setup program updates the Windows registry for Microsoft Access.
- When Setup is finished, try to start Microsoft Access again.
Modification Type: | Major | Last Reviewed: | 10/29/2003 |
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Keywords: | kberrmsg kbprb kbsetup KB141294 |
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