Sound Problems with ESS ES1688 AudioDrive (139990)



The information in this article applies to:

  • Microsoft Windows 95
  • Microsoft Windows for Workgroups 3.1
  • Microsoft Windows for Workgroups 3.11
  • Microsoft Windows 3.1
  • Microsoft Windows 3.11

This article was previously published under Q139990

SYMPTOMS

When you are using a computer with an ESS Technology ES1688 AudioDrive sound card, sound may not work correctly, or may cause programs to stop responding (hang). In Windows 95, Device Manager may report a problem with the device, or that the device is not working correctly.

CAUSE

The ESS AudioDrive device that exhibits this problem is an onboard chip that is soldered to the motherboard. Early versions of the driver for this device cannot reserve physical RAM, and allow the driver to be paged out of virtual memory. The device is not capable of using virtual memory.

Although Windows 95 correctly identifies the sound card as an ESS Technology ES1688 AudioDrive sound card, the Windows 95 driver does not work correctly.

RESOLUTION

Windows 95

To resolve this issue, use either of the following methods:
  • Remove the ES1688 sound card driver and replace it with the ESS ES688 sound card driver. To do so, follow these steps:

    1. In Control Panel, double-click the System icon.
    2. On the Device Manager tab, double-click the Sound, Video, And Game Controllers branch.
    3. Click the ESS Technology ES1688 AudioDrive device, and then click Remove. Click Close or OK until you return to Control Panel.
    4. In Control Panel, double-click the Add New Hardware icon.
    5. Click Next, click the No option, and then click Next.
    6. In the Hardware Types box, click Sound, Video, And Game Controllers, and then click Next.
    7. In the Manufacturers box, click ESS Technology, Inc.
    8. In the Models box, click ESS ES688 AudioDrive, and then click Next.
    9. Click Next to accept the default hardware settings for the audio card.
    10. Click Finish.
    11. Click Yes to restart your computer.
  • Obtain the ESS AudioDrive drivers version 4.2 or higher from ESS Technology. Or, obtain the latest version of Media Pilot from Compaq Computer Corporation. Media Pilot contains an update to the ESS AudioDrive drivers.

Windows and Windows for Workgroups 3.1 and 3.11

Obtain the ESS AudioDrive drivers version 4.2 or higher from ESS Technology. Or, obtain the latest version of Media Pilot from Compaq Computer Corporation. Media Pilot contains an update to the ESS AudioDrive drivers.

MORE INFORMATION

Although Windows 95 detects the ES1688 AudioDrive device, the driver does not work correctly. Replacing the driver with the ES688 AudioDrive driver corrects the problem.

The third-party products discussed in this article are manufactured by vendors independent of Microsoft; we make no warranty, implied or otherwise, regarding these products' performance or reliability.

Modification Type:MajorLast Reviewed:12/10/2000
Keywords:KB139990