Compressed Audio Fails or Errors Occur After Windows Restart (139395)



The information in this article applies to:

  • Microsoft Multimedia Pack 1.0
  • Microsoft Windows 3.0
  • Microsoft Windows 3.1
  • Microsoft Windows 3.11

This article was previously published under Q139395

SYMPTOMS

The first time sound is used in your multimedia program the sound plays as expected. However, when you exit and then restart Windows you experience sound problems. This also occurs when you reinstall the program.

In a program supporting sound, audio may not work, or you may receive one of the error messages when you attempt to play sound:
No wave device exists that can play files in the current format.
-or-
Undetectable problem in the specified device driver.
-or-
Multimedia device failed.
-or-
Integer divide by zero.

CAUSE

Duplicate Audio Compression Manager (MSACM) files or System.ini files exist on the computer.

RESOLUTION

NOTE: The following steps involve searching for, deleting, and renaming files and folders. For more information about how to accomplish these tasks in Windows, see your Windows printed documentation or online help.

To remove the duplicate files, do the following:

  1. Search your hard drive for the following files:

    - Msacm.drv
    - Msacm.dll
    - Msadpcm.acm

    Only one copy of these files should reside on your computer. Rename or delete any copies not found in the Windows\System folder.
  2. Search your hard drive for the following file:

    - System.ini

    Only one copy of these files should reside on your computer. Rename or delete any copies not found in the Windows folder.

MORE INFORMATION

For more information on troubleshooting compressed audio problems, please see the following article in the Microsoft Knowledge Base:

121132 MSACM 2.0: Compressed Audio Will Not Play


Modification Type:MinorLast Reviewed:7/7/2005
Keywords:KB139395