OFF95: Setup Err Msg "\\D.\A.\SETUP.EXE Not Found" (139025)



The information in this article applies to:

  • Microsoft Office for Windows 95, Standard edition, when used with:
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98
  • Microsoft Office for Windows 95 Professional edition, when used with:
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98

This article was previously published under Q139025

SYMPTOMS

You may receive the following message when you set up Microsoft Office for Windows 95:
A Required .dll file, \\D. \A. \SETUP.EXE was not found
Note that the letter after the double slash may vary. This letter usually indicates the drive letter of the CD-ROM drive.

CAUSE

This message may appear after you start Microsoft Windows 95 in Safe mode and you attempt to install Microsoft Office 7.0 on compact disc.

Starting Windows in Safe mode is a standard troubleshooting technique that you can use when other problems occur when you install a program. On some computers, starting Microsoft Windows in Safe mode causes the message to appear.

Microsoft has not determined which specific CD-ROM drives cause the problem. Instead of starting in Safe mode, try one of the methods in this article to work around the problem, and then install the program.

WORKAROUND

Method 1

Verify that the compact disc and compact disc caddy (if applicable) are clean and free of contamination that might interfere with reading the disc. Follow the CD-ROM drive manufacturer recommendations regarding cleaning compact discs and caddies.

Method 2

Add the /s switch to the MSCDEX line in the Autoexec.bat file; for example add "/s" (without the quotation marks) to the end of the line that is similar to the following:
   c:\windows\command\mscdex /d:ms001 /s
				
The /S switch works only with the most recent version of MSCDEX (version 2.25) which is included with Microsoft Windows 95. If the switch doesn't work, determine which version of Mscdex.Exe you are using.

Method 3

This method works only if the CD-ROM real mode drivers are loaded in the Autoexec.bat and Config.sys files.

NOTE: If you are not familiar with these drivers, do not use this method.

The CD-ROM driver manual is the best source of information for determining which drivers are required for the drive to function properly.

For additional information, please see the following article in the Microsoft Knowledge Base:

151634 Protected-Mode CD-ROM Drive Support in Windows 95


If you use the steps for this method, write down the settings you change.

To use this method, use the following steps:

  1. On the taskbar, click Start, point to Settings, and then click Control Panel.
  2. Double-click the System icon.
  3. On the Performance tab, click File System.
  4. Click the Hard Disk tab, move the Read-Ahead Optimization slider to None.
  5. Click the CD-ROM tab, move the Supplemental Cache Size slider to Small.
  6. Click the Troubleshooting tab and verify that the last four check boxes under Settings are selected.
  7. Click OK.
  8. Click the Device Manager tab and click "View device by connection."
  9. Locate the CD-ROM drive controller and click it.

    NOTE: This controller may be a small computer system interface (SCSI) or proprietary controller.
  10. Click Properties.
  11. Click the General tab, clear the Original Configuration check box under Device Usage.

    NOTE: This step forces the computer to use the real mode CD-ROM drivers.
  12. Continue to click OK until you close the open dialog boxes.
  13. Restart the computer in normal mode.

    NOTE: Microsoft recommends that you restart the computer and interactively disable entries in the Autoexec.Bat and Config.Sys files.

    After you restart, the computer is running in protected mode except for the CD-ROM drive.
  14. Run the Microsoft Office 7.0 Setup program.
  15. After Setup is finished, double-click the System icon in the Control Panel, reselect the settings you wrote down earlier, and restart the computer.

Method 4

If the computer has not received any general maintenance for a year or more or has old dynamic-link library (DLL) files and possibly damaged files, it may be necessary to reformat the hard disk and reinstall Microsoft Windows 95 and Microsoft Office 7.0.

Modification Type:MajorLast Reviewed:11/24/2003
Keywords:kberrmsg kbprb kbsetup KB139025