Real Mode TCP/IP Custom Blocking Hook Causes Computer to Hang (137799)
The information in this article applies to:
- Microsoft LAN Manager 2.2
- Microsoft Windows for Workgroups 3.1
This article was previously published under Q137799 SYMPTOMS
On your computer with the real mode TCP/IP protocol stack installed, when
you run a Winsock program that uses a custom blocking hook routine, the
program hangs during data transfers.
This problem does not occur with every Winsock program that uses a custom
blocking hook routine.
CAUSE
Your custom blocking hook routine does not dispatch WM_TIMER messages
causing your Winsock program to hang.
The default blocking hook dispatches all messages. Some programs require a
custom blocking hook to provide additional functionality to the program,
however, this custom blocking hook may lack the ability to dispatch
WM_TIMER messages.
RESOLUTION
In the custom blocking hook routine, include a PeekMessage() call to remove
WM_TIMER messages and dispatch them.
Modification Type: | Major | Last Reviewed: | 10/23/2003 |
---|
Keywords: | KB137799 |
---|
|