PPT: Errors in PowerPoint Due to Multiple User Profiles (137756)



The information in this article applies to:

  • Microsoft PowerPoint for Windows 95
  • Microsoft PowerPoint for Windows 4.0
  • Microsoft PowerPoint for Windows 4.0a
  • Microsoft PowerPoint for Windows 4.0c
  • Microsoft PowerPoint for Macintosh 4.0

This article was previously published under Q137756
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

SYMPTOMS

Case 1. When you run the AutoContent Wizard, you receive the following error message:
Sorry, PowerPoint could not start or locate 'PPT Tools.'
You should run Setup and reinstall.
Case 2. When you attempt to open a PowerPoint 4.0 file into PowerPoint 7.0, you receive the following error message:
Sorry, this type of file cannot be opened by PowerPoint.
Case 3. When you attempt to run Quick Preview, nothing happens.

Case 4. The Interactive Settings command is not on the Tools menu.

Case 5. When you attempt to run Help, nothing happens.

CAUSE

Cases 1-4. This problem occurs in the following situations:
  • You are using a computer with multiple Windows 95 user profiles and the user profile that you are logged on to is different from the user profile that you used when you installed PowerPoint. The user profile that was active when you installed PowerPoint contains the correct Registry information for the converters for the previous versions of PowerPoint.
  • The Registry information for PowerPoint is incorrect or is corrupted. If you are on a computer that has multiple Windows 95 user profiles, all users who log on will experience one or more of these symptoms.
Case 5.
  • You are logged on as another user on a computer using the Windows NT 3.51 operating system. For example, this problem occurs if you were logged on as Administrator when you installed PowerPoint, but you are logged on as a user when you run PowerPoint. When you are logged on as Administrator, the Pptools.ppa file is correctly registered in the Windows NT Registry; while you are logged on as a user, the Pptools.ppa file is not registered.

WORKAROUND

For all cases, choose the appropriate method to work around this problem:

Method 1

Close all programs and log on to Windows using the profile that you used when you installed PowerPoint 7.0.

Method 2

Reinstall PowerPoint 7.0 using the /y switch for every user profile that experiences the problem. To do this,
  1. Log on using a profile that is unable to open earlier versions of PowerPoint.
  2. In Windows Explorer, open the MSOffice or Powerpnt folder.
  3. Copy the Office Setup or PowerPoint Setup shortcut to the desktop.
  4. Right-click the Setup shortcut, and click Properties.
  5. Click the Shortcut tab.
  6. Modify the contents of the Target box.

    The Target box contains the following (or similar) instruction:
          C:\Msoffice\Office\Setup\Acme.exe /W Off95std.stf
    						
    Add a /y to the end of this line so that it looks like this:
          C:\Msoffice\Office\Setup\Acme.exe /W Off95std.stf /y
    						
  7. Click OK.
  8. Double-click the shortcut.
  9. In the Maintenance Mode Setup dialog box, click Reinstall.

    While the Setup program runs, it does not copy any files. Instead, it updates the Windows 95 registry so that the current user profile can use all the Office features.
  10. Repeat steps a-i for each user profile.

Method 3

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it. If you are running Windows NT, you should also update your Emergency Repair Disk (ERD).

If Method 1 and 2 are unsuccessful, export the Registry keys related to PowerPoint and re-register the program, using these steps:
  1. Click the Windows Start button, and then click Run.
  2. In the Open box, type Regedit, and then click OK.
  3. Open the HKEY_CLASSES_ROOT key.
  4. Locate and select the .ppt key.
  5. On the Registry menu, click Export Registry File.
  6. In the Save In box, select the Desktop. Type a file name for the exported file, and click Save.
  7. Select the .ppt key if it is not already selected, and click Delete on the Edit menu. Click Yes in the message box asking you to delete the registry key.
  8. Repeat steps d through g for the .pot, .pwz, and .pps keys.
  9. Start PowerPoint to re-register it.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article. This problem was corrected in Microsoft PowerPoint 97 for Windows.

REFERENCES

For additional information, please see the following article here in the Microsoft Knowledge Base:

126556 MS Query Button Doesn't Appear in Open Data Source Dialog Box


Modification Type:MinorLast Reviewed:8/17/2005
Keywords:kbenv kberrmsg kbinterop kbprb kbsetup KB137756