PRB: Directories & Registry Entries Left After Deinstall (134981)
The information in this article applies to:
- Microsoft Visual FoxPro for Windows 3.0
This article was previously published under Q134981 SYMPTOMS
In Windows NT, Windows version 3.1, and Windows for Workgroups, removing
all Visual FoxPro files by using the Visual FoxPro Setup program does not
remove the main Visual FoxPro directories and related subdirectories. Also,
in Windows NT and Windows 95, registry information is not removed.
CAUSE
This is by design. The Visual FoxPro directory tree is not removed for
safety reasons. Removing the directory tree could also delete user files
and adding in the algorithm to check for user files versus FoxPro files
would have added an additional level of complexity to the removal option.
RESOLUTION
After the removal process has completed, you can delete the directory where
Visual FoxPro was installed by using File Manager.
To remove the Registry entries in Windows 95 and Windows NT, you need to
delete the Visual FoxPro key and all its subkeys by using the Registry
Editor. Microsoft does not support the use of the Registry Editor, so you
are urged to exercise extreme caution when working with the registry files.
The Visual FoxPro registry entries are found in HKEY_CURRENT_USER on Local
Machine in the Microsoft folder.
STATUS
This behavior is by design.
Modification Type: | Major | Last Reviewed: | 2/15/2000 |
---|
Keywords: | KB134981 |
---|
|