Cannot Print from MS-DOS to JetDirect Printer in Direct Mode (134778)
The information in this article applies to:
This article was previously published under Q134778 SYMPTOMS
When you try to capture a printer port to a printer attached to a Hewlett-
Packard (HP) JetDirect device in Direct mode (without a NetWare server),
you may receive the following error message:
Windows Networking
The following error occurred while trying to connect
LPT1 to \\HP_Network_Printers\<printername>
The computer or sharename could not be found. Make sure you typed it
correctly, and try again.
You may see this error message when you click Yes in the Add Printer
Wizard when you are prompted "Do you print from MS-DOS-based programs?".
CAUSE
You can connect to HP JetDirect devices in Direct mode with Universal
Naming Convention (UNC) connections only. You cannot capture a printer
port to an HP JetDirect device in Direct mode.
WORKAROUND
A workaround for this problem is to use Novell's CAPTURE command in your
login script. The Windows 95 login script processor recognizes this
command, and it spawns the results to all subsequent VMs.
STATUS
Microsoft is researching this problem and will post new information here
in the Microsoft Knowledge Base as it becomes available.
MORE INFORMATION
When the Add Printer Wizard prompts you to capture a printer port, the
network path is automatically inserted and cannot be changed (as the error
message stated above suggests). Many MS-DOS-based programs cannot print
unless the network printer is redirected through a local port.
Modification Type: | Major | Last Reviewed: | 12/17/2000 |
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Keywords: | KB134778 |
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