FIX: Cannot Open Database and No Message Is Displayed (134315)
The information in this article applies to:
- Microsoft Visual FoxPro for Windows 3.0
- Microsoft Visual FoxPro for Windows 3.0b
This article was previously published under Q134315 SYMPTOMS
When attempting to open a Visual FoxPro database (.DBC) by using the menu
options or by clicking the Open button on the Standard toolbar, Visual
FoxPro does not open the database or issue a message if the database has
been open exclusively by another user or in a different private data
session.
CAUSE
The database is already open exclusively on a second machine or in another
Visual FoxPro session on the same machine. When the database is already
open, Visual FoxPro echoes the OPEN DATABASE command to the Command window,
but does not execute it.
WORKAROUND
Here are three possible workarounds:
- Attempt to open the database by executing the OPEN DATABASE command that
was echoed to the Command window. The error "File Access Denied" occurs
because the database is already opened exclusively.
-or-
- Execute the OPEN DATABASE command in a program.
-or-
- Open the database SHARED on all machines and in each Visual FoxPro
session.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article. This problem has been fixed in
Visual FoxPro 5.0 for Windows.
| Modification Type: | Major | Last Reviewed: | 9/30/2003 |
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| Keywords: | kbBug kbfix kbvfp500fix KB134315 |
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