CG2: ClipArt Gallery Not Available If Added in Maintenance Mode (133427)
The information in this article applies to:
- Microsoft ClipArt Gallery for Windows 95 2.0
- Microsoft Office for Windows 95
This article was previously published under Q133427 SYMPTOMS
After you run Microsoft Office Setup in maintenance mode, if you add the
Clip Art Gallery item, Microsoft ClipArt Gallery may not be available in
the Object Type list when you insert an object in your document.
Additionally, in Microsoft PowerPoint, if you click the Insert Clip Art
button or click Clip Art on the Insert menu, you receive the following
error message:
The server application, source file, or item cannot be found. You should
reinstall the server application.
CAUSE
This problem occurs if you run the Office Setup program in maintenance
mode, and you remove the Microsoft Clip Art item, and you then run Setup
again and add the Microsoft Clip Art item.
When you run Office Setup in maintenance mode and remove the ClipArt
Gallery, the actual ClipArt Gallery files are not removed from your
computer. This is by design, because ClipArt Gallery is a shared
application. However, if you then run Setup and add the ClipArt Gallery
item again, the registry entries for the ClipArt Gallery are removed, and
you cannot use the ClipArt Gallery in your applications.
RESOLUTION
To resolve this problem and run ClipArt Gallery again in your applications,
do the following to register ClipArt Gallery:
- Use My Computer or Windows Explorer to locate the file Artgalry.exe.
This file is located in the Program Files\Common Files\Microsoft
Shared\Artgalry folder.
- Double-click the Artgalry.exe file.
You receive the following error message:
The ClipArt Gallery may only be used to embed objects. It must be
started from within another application. - Click OK.
The ClipArt Gallery is now registered correctly on your computer. Note that
you may need to close and then start your program again before Microsoft
ClipArt Gallery appears in the Object dialog box.
Note that if you run Office Setup in maintenance mode and click Remove All,
and then run Setup again and install ClipArt Gallery along with the other
Office items, ClipArt Gallery is available as expected. This problem only
occurs when you remove ClipArt Gallery using the Add/Remove button while
running Office Setup in maintenance mode, and you then re-install ClipArt
Gallery.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article. This problem was corrected
in Microsoft Office 97.
Modification Type: | Minor | Last Reviewed: | 8/16/2005 |
---|
Keywords: | kbprb KB133427 |
---|
|