"Can't Access" Adding Table Using UNC Network Drive (132481)
The information in this article applies to:
- Microsoft Excel for Windows 95
- Microsoft Query
This article was previously published under Q132481 SYMPTOMS
In Microsoft Query, when you add a table that is located on a network
drive, you may receive the following error message
Can't access table <drive>:\<folder>\<table>
where <drive>:\<folder> is the default drive and folder for the data source
that you are using (for example, C:\Program Files\Common Files\Microsoft
Shared\MSquery), and <table> is the table that you added from the network
drive.
CAUSE
This problem occurs when you add a table using a Universal Naming
Convention (UNC) drive connection in the Add Tables dialog box. For
example, if you enter the following in the Add Tables dialog box
when you click Add, the network share is connected as expected, and the
folders on this share appear in the Directories list in the Add Tables
dialog box. However, when you click a table in the Table Name list, and
click Add, you receive the error message indicating that Microsoft Query
cannot find the table. Additionally, the error message indicates that
Microsoft Query is looking for the table in the default directory for the
data source instead of on the network drive.
This behavior occurs with data sources that use paths, such as a dBASE data
source.
Note that this behavior does not occur if you enter the entire path to the
table file in the Table Name box. For example, if you enter the following
path in the Table Name box
\\computer1\share\files\customer.dbf
the table is added as expected.
WORKAROUND
To work around this behavior, make a real network connection to the network
drive that contains the table file that you want to add. To do this, use
the following procedure:
- In the Add Tables dialog box, click the Network button.
- In the Path box, enter the UNC network name, such as
\\computer1\share.
- Select or clear the Reconnect At Logon check box depending on whether
or not you want to automatically connect to this share each time you
log on to the network. Click OK.
- In the Drives list in the Add Tables dialog box, click the share you
connected in Step 3 above.
- In the Directories list, select the folder that contains the table
that you want to add.
- In the Table Name list, click the table you want to add, and then
click Add.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article. We are researching this problem
and will post new information here in the Microsoft Knowledge Base as it
becomes available.
Modification Type: | Minor | Last Reviewed: | 8/15/2005 |
---|
Keywords: | KB132481 |
---|
|