Works 95: IPF When Starting Works for Windows 95 (4.0) (130502)



The information in this article applies to:

  • Microsoft Works 4.5
  • Microsoft Works 4.5a
  • Microsoft Works for Windows 95, version 4.0
  • Microsoft Works for Windows 95, version 4.0 4.0a

This article was previously published under Q130502

SYMPTOMS

When you start Works for Windows 95, you may receive the following error message if you are using a Logitech pointing device, Kensington mouse, or a Microsoft PS/2 port mouse:
This program has performed an illegal operation and will be shut down.
Clicking the Details button reveals the following:
MSWORKS caused an Invalid Page Fault in module MSWORKS.EXE at 0137:00649db5. <address may vary>
NOTE: You may also receive the "Invalid Page Fault" error message while using the spelling checker.

CAUSE

Pointing Device Behavior

The "SmartMove" setting in the Logitech MouseWare Control Center is enabled. If the "SmartMove" setting is not disabled, then clicking the Logitech mouse in Control Panel rewrites the Load= line in the Win.ini file if you have already deleted the Load= line or removed it with the REM command. (Note that the Mouse Control Center executable file is Wmousecc.exe.)

-or-

The Logitech MouseWare utility Wbuttons.exe or Lbuttons.exe, or a different mouse-related utility, such as Pointer.exe, is loading from the Load= or Run= line located in your Win.ini file.

Spelling Checker Behavior

This can be caused by the Wbuttons.exe driver being loaded in the load= line of the Win.ini file. To correct this problem, see the "Disabling Wbuttons.exe, Lbuttons.exe, or Other Utilities" section below.

RESOLUTION

Disabling the SmartMove Setting

The following steps apply to MouseWare versions 6.4 and later. To determine the version, click the green, red, and black Logitech icon in the MouseWare Control Center box.

NOTE: These steps may vary slightly depending on the pointing device being used.

To disable the SmartMove setting, do the following:

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click the LogiMouse or Mouse option.

    The MouseWare Control Center box should appear. If the Mouse Properties box appears instead, click General, and then click Options, to get to the MouseWare Control Center.
  3. Click the SmartMove check box to clear it. Click OK.

-or-

If you were not able to disable SmartMove using the steps above, you can also disable this option using the steps below:

  1. Click Start, and then click Programs.
  2. Click Logitech Senseware, and then click Control Center.
  3. Click to clear the SmartMove check box, and then click OK.
If the above steps do not solve the problem, disable the Wbuttons.exe, Lbuttons.exe, or other utility in the Win.ini file using the following steps.

Disabling Wbuttons.exe, Lbuttons.exe, or Other Utilities

  1. Click Start, and then click Run.
  2. Type Win.ini and click OK.
  3. Remove the executable (Wbuttons.exe, Lbuttons.exe, and so on.) from the Load= or Run= line.
  4. On the File menu, click Save.
  5. On the File menu, click Exit.
  6. Click Start, and then click Shut Down.
  7. Click Restart The Computer and click Yes.
Wbuttons.exe, Lbuttons.exe and Pointer.exe are not required when running Windows 95 or Works for Windows 95.

NOTE: If you do not have a Logitech pointing device, you may need to do the following to turn off SmartMove:

  1. Click Start, point to Programs, and click Mouse Control Center.
  2. Click the Mouse controls and turn off the SmartMove option there.
See the steps above for more information about how to turn off the SmartMove option.

MORE INFORMATION

Microsoft has confirmed that this is a problem in Works version 4.0.

This problem was corrected in Works version 4.0a and later.
If you need MouseWare's WBUTTONS functionality in Windows 95, contact Logitech for the latest version of the MouseWare utility. The updated version of this program, version 6.6, functions properly with Works 4.0 if the SmartMove option is turned off.

Logitech Inc.
Sales: (800) 231-7717
Tech Support: (510) 795-0427
BBS: (510) 795-0408

To obtain faxed information about using Logitech mice with Windows 95, contact Logitech's Faxback system at (800) 245-0000, and request the document titled "Using Logitech Pointing Devices with Windows 95."

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:11/15/2004
Keywords:kbbug kbpending KB130502