HPMON Logs Event 1044 But Job Prints Correctly (129007)
The information in this article applies to:
- Microsoft Windows NT Workstation 3.5
- Microsoft Windows NT Workstation 3.51
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 3.5
- Microsoft Windows NT Server 3.51
- Microsoft Windows NT Server 4.0
This article was previously published under Q129007 SYMPTOMS
HPMON may repeatedly log the following application event when you print
through an Hewlett-Packard (HP) JetDirect adapter:
Event Id: 1044
Description: Lost connection with address <JetDirect address>.
Printing will continue when the connection is re-established.
The print jobs print correctly after the error is logged.
CAUSE
HPMON uses the DLC protocol to send print jobs to HP JetDirect adapters. In
Job Based mode, a Windows NT print server connects to the JetDirect
adapter, sends a job, and disconnects, allowing the adapter can receive
connections from other print servers. In Continuous mode, the print server
makes a connection and never disconnects, preventing other servers from
using the JetDirect.
The JetDirect adapter resets itself after each disconnect, and during the
reset the adapter does not accept new connections. If a Windows NT print
server sends numerous jobs back-to-back in Job Based mode, the JetDirect is
resets itself often after a disconnect when the next connection request
arrives. When the JetDirect denies the connection, HPMON on the Windows NT
print server logs error 1044, waits briefly, and then tries to connect
again (usually succeeding).
RESOLUTION
Although the logged events in this situation do not indicate a problem,
they can fill the event log. To avoid this, use Continuous mode instead of
Job Based mode:
Windows NT 3.x- In Print Manager, select the printer encountering this error.
- On the Printer menu, click Properties.
- Click Settings and then click Timers.
- Change Connection type from Job Based to Continuous.
Windows NT 4.0- In the Printers folder, select the printer encountering this error.
- On the File menu, click Properties.
- Select the Ports tab.
- Click Configure Port and then click Timers.
- Change Connection type from Job Based to Continuous.
Modification Type: | Major | Last Reviewed: | 5/6/2003 |
---|
Keywords: | kbprint KB129007 |
---|
|