Print Job to LPR Printer Does Not Print (128352)
The information in this article applies to:
- Microsoft Windows NT Workstation 3.5
- Microsoft Windows NT Workstation 3.51
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 3.5
- Microsoft Windows NT Server 3.51
- Microsoft Windows NT Server 4.0
This article was previously published under Q128352 SYMPTOMS
When you print from a computer running Microsoft Network Client for MS-DOS
or Windows for Workgroups version 3.11 to a Line Printer Remote (LPR)
protocol printer that is connected to a Windows NT Line Printer Daemon
(LPD) server, the print job does not print and the following is written to
the system log:
Event ID: 2001
Source: LPR Print Monitor
Type: Warning
Description: Cannot Reach the Destination.
CAUSE
This problem occurs if you do not have proper permissions to write to the
subdirectory, because the LPR command (LPR.EXE) needs to write a temporary
file to the %SystemRoot%\SYSTEM32 subdirectory on the Windows NT computer.
The Everyone group has Change permission by default. If the Administrator
removes this right for the \SYSTEM32 subdirectory, the above error message
appears.
RESOLUTION
To correct this problem, do one of the following:
- Log on as one of the Administrators on the client computer.
- Grant the user on the client computer Change permissions to the
%SystemRoot%\SYSTEM32 subdirectory on the Windows NT computer.
NOTE: Change permission is the default security for the System32
directory. The problem described above occurs when an administrator has
changed the default permissions. Access to the Windows NT directory tree
is protected by share permissions. Directory permissions are a secondary
level of security.
For additional information, please see the following articles in the
Microsoft Knowledge Base:
137912: File Permissions on \SYSTEM32 Affect All Subdirectories
138593: Unable to Print to WinNT LPR Printers after Applying SP2
Modification Type: | Major | Last Reviewed: | 7/11/2006 |
---|
Keywords: | kbprint KB128352 |
---|
|