Works Err Msg: This Application uses CTL3DV2.DLL... (128342)



The information in this article applies to:

  • Microsoft Works 3.0
  • Microsoft Works 3.0a
  • Microsoft Works 3.0b

This article was previously published under Q128342
3.00 3.00a 3.00b WINDOWS kbsetup kberrmsg kbprb

SYMPTOMS

When you double-click the Microsoft Works icon to start the program, you receive the following error:
This application uses CTL3DV2.DLL, which has not been correctly installed.
If you choose the OK button to close the error message, Works starts and appears to run normally.

CAUSE

This error can be caused by one or more of the following:

  • Multiple copies of, or an improperly located copy of, CTL3DV2.DLL
  • A damaged or corrupted CTL3DV2.DLL file
  • A damaged or corrupted COMMDLG.DLL file

RESOLUTION

I. Determine if There Are Multiple Copies of CTL3DV2.DLL

For more information about how to perform the following task in Windows, see your Windows printed documentation or online Help.

  1. Search the hard drive for multiple copies of CTL3DV2.DLL.
  2. If more than one copy of CTL3DV2.DLL is found and Windows is installed locally, remove all copies except the one located in the Windows SYSTEM subdirectory.
  3. If more than one copy of CTL3DV2.DLL is found and Windows is shared from a network server, remove all copies except the one located in the shared Windows directory on the server (that is, the directory where all of the Windows system files are located.)
  4. If only one copy of the file is found and it is located in the Windows SYSTEM subdirectory or the shared Windows directory on the server, follow the steps below.

II. Replace the CTL3DV2.DLL File with a New Copy from Your Works Disks

For more information about how to perform this task in Windows, see your Windows printed documentation or online Help.

  1. If you are using Windows 3.x, exit Windows. If you are using Windows 95, click the Start button, point to Programs, then click the MS-DOS Prompt icon. At the MS-DOS command prompt, rename the existing version of CTL3DV2.DLL to CTL3DV2.OLD.
  2. Switch to the directory containing the file DECOMP.EXE: If Works was installed on an individual computer, switch to the MSWORKS\SETUP directory on the hard drive. If Works was installed on a network server, change to the shared Works directory on the server.
  3. Insert Disk 3 if you are using Works 3.0, or Disk 4 if you are using Works version 3.0a or 3.0b, and type the following at the MS-DOS command prompt:

    decomp <drive>:\ctl3dv2.dl_ <path>ctl3dv2.dll

    where <drive> is the drive letter where the Works Setup disk is located, and <path> is the complete path to the Windows SYSTEM subdirectory. For example:

    decomp a:\ctl3dv2.dl_ c:\windows\system\ctl3dv2.dll

  4. Start Windows and Works to determine if the problem has been resolved. If not, continue with the steps below.

III. Replace the COMMDLG.DLL File with a New Copy from Your Windows Disks

For more information about how to perform the following task in Windows, see your Windows printed documentation or online Help.

  1. Search the hard drive for multiple copies of COMMDLG.DLL.
  2. If you are using Windows 3.x, exit Windows. If you are using Windows 95, click the Start button, point to Programs, then click the MS-DOS Prompt icon. At the MS-DOS command prompt, rename each existing copy of COMMDLG.DLL to COMMDLG.OLD
  3. Change to the directory containing EXPAND.EXE (it's usually in the Windows directory).
  4. If you are using Windows 3.1, or Windows 3.11, insert your Windows Setup disk 4 into the floppy disk drive. If you are using Windows for Workgroups 3.11, insert Setup disk 1 (1.44 MB) or Setup disk 2 (1.2 MB) and type the following at the MS-DOS command prompt:

    expand <drive>:\commdlg.dl_ <path>commdlg.dll

    where <drive> is the drive letter where the Windows Setup disk is located, and <path> is the complete path to the Windows SYSTEM subdirectory.

    If you are using Windows 95 and purchased it on diskettes, insert disk 1 and type the following at the command prompt:

    extract /L <path> <drive>:\precopy1.cab commdlg.dll

    If you are using Windows 95 CD-ROM edition, insert the disc and type the following at the command prompt:

    extract /L <path> <drive>:\win95\precopy1.cab commdlg.dll

  5. Start Windows and Works.

MORE INFORMATION

If CTL3DV2.DLL is located in the MSWORKS directory, this error occurs whether or not there is a copy in the Windows SYSTEM subdirectory if you are running Windows 3.x. The most common cause of this error message is duplicate copies of CTL3DV2.DLL on the system. Thoroughly search all directory paths and network drives for duplicate copies of CTL3DV2.DLL before completing steps II or III above. If there are no duplicate copies of CTL3DV2.DLL, be certain that the existing file is located in the Windows SYSTEM subdirectory.

Modification Type:MajorLast Reviewed:9/26/2003
Keywords:KB128342