Errors Using Non-TAPI Programs If TAPI Program Set to Answer (127994)
The information in this article applies to:
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows 98 Second Edition
This article was previously published under Q127994 If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware: SYMPTOMS
When you try to use a 16-bit non-TAPI-aware communications program in
Windows 95/98, you may receive one of the following error messages:
- The port is already open.
- Could not initialize port.
- The selected COM port is either not supported or is being used by another device. Select another port.
When you run modem diagnostics from the Modems utility in Control Panel,
you receive the following error message with "OPENCOMM" in the title bar:
Port already open
CAUSE
This behavior can occur for the following reasons:
- If the Dial-Up Networking server is installed and set to Allow
Caller Access, the COM port is effectively locked to non-TAPI-
aware applications. This may not be obvious because the Dial-Up
Networking server does not place an icon on the taskbar.
- If you set Microsoft Fax to answer incoming calls automatically,
the COM port is effectively locked to non-TAPI-aware applications.
- There is a hardware (IRQ) conflict. To check for IRQ conflicts, use the right-click My Computer, and then click Properties on the menu that appears. Click the Device Manager tab, then check the properties for each device.
RESOLUTION
To work around this behavior, you must set the TAPI-aware application to
not answer incoming calls. After you have used the non-TAPI-aware
application, set the TAPI-aware application to answer incoming calls
again.
The Dial-Up Networking server (available as an add-on) and Microsoft Fax
are examples of TAPI-aware applications that you can set to answer
incoming calls automatically. To set these applications to not answer
incoming calls, follow the steps in the sections below.
Dial-Up Networking Server- Double-click My Computer, and then click Dial-Up Networking.
- On the Connections menu, click Dial-Up Server.
- Click No Caller Access, and then click OK.
Microsoft Fax- Double-click the Microsoft Fax Status icon on the taskbar.
NOTE: If this icon is not present, first double-click the Inbox icon on the desktop, then click the Fax profile if prompted.
- On the Options menu, click Modem Properties, and then click Don't Answer in the Answer Mode section.
MORE INFORMATION
These error messages do not occur when you are using TAPI-aware programs
such as HyperTerminal.
Modification Type: | Major | Last Reviewed: | 8/8/2006 |
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Keywords: | kberrmsg kbprb KB127994 |
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