Cannot Find Multimedia Works Files on Works/Money CD (125521)
The information in this article applies to:
This article was previously published under Q125521 SYMPTOMS
If you have the Works/Money CD and you try to access Help or the
Tutorial, you may receive the following error messages
Please make sure the Multimedia Works CD-ROM is in the drive <CD-ROM
Drive>, or specify an alternative drive for Works to use
where <CD-ROM Drive> is the letter of your CD-ROM drive. After you choose
OK, you will receive the following:
Cannot find Multimedia Works for Windows files on drive <CD-ROM
Drive>. Please specify another drive.
When you try to run the "Introducing Works" icon, you may receive the error
message "The working directory is invalid." After you choose OK, the
following is displayed:
Cannot find file <CD-ROM Drive>:\demo\workscbt.exe (or one of its
components). Check to ensure the path and filename are correct and that
all required libraries are available.
In addition, you may receive the "Cannot run help" error message if you use
Works for Windows, multimedia edition, version 3.0 and upgrade to Windows
95. (The Win.ini and Msworks3.ini files entries are always pointing
towards drive A instead of to the correct CD-ROM drive letter.)
CAUSE
This problem occurs if Works was installed from the standard Works CD, but
the new Works/Money CD is now in the drive. The Help files in the standard
Works CD are located in the HELP directory and all of the paths in the .INI
files and the Introducing Works icon properties point to this location.
On the Works/Money CD, the Help files are located in the MSWORKS\HELP
subdirectory. When you have the Works/Money CD in the drive and try to
access the standard Works Help, Tutorial, or Introducing Works files, the
location in the .INI files and icon properties points to the wrong
location.
RESOLUTION
You can either edit the .INI files and the Introducing Works icon
properties to point to the correct locations, or remove and then reinstall
Works.
REMOVING AND REINSTALLING WORKS
- Windows 95: Click the Start button, point to Programs, point to
Microsoft Works for Windows, and click Microsoft Works Setup.
Windows 3.1: Double-click the Microsoft Works Setup icon in the
Microsoft Works for Windows group in Program Manager.
- Choose the Remove All button.
- When Setup has finished removing the current installation of Works,
follow the Setup instructions that came with Works for reinstalling
the product.
The .INI file settings and icon properties should now be rewritten to point
to the correct location.
NOTE: If there are any errors displayed when you attempt to run setup to
remove Works, rename the Works SETUP.STF file and then reinstall Works. The
SETUP.STF file is usually located in the C:\MSWORKS\SETUP directory on your
hard drive.
EDITING THE .INI FILES AND ICON PROPERTIES
The .INI files should contain the following paths, where <CD-ROM Drive> is
the letter of your CD-ROM drive.
The MSWORKS3.INI File
--------------------
[MM WORKS]
HelpFilePath=<CD-ROM Drive>:\MSWORKS\HELP\MSWORKS.MVB
The VIEWER.INI File
-------------------
[files]
MSWORKS.MVB=<CD-ROM Drive>:\MSWORKS\help\
The WIN.INI File
----------------
[MM WORKS]
Path=<CD-ROM Drive>:\MSWORKS\
Next, the Introducing Works icon properties should be changed using the
following steps:
- Select the Introducing Works icon.
- Modify the icon properties to include the following:
Command Line: <CD-ROM Drive>:\MSWORKS\DEMO\WORKSCBT.EXE DEMO.LES
Working Directory: <CD-ROM Drive>:\MSWORKS\DEMO
Icon: <CD-ROM Drive>:\MSWORKS\DEMO\DEMO.ICO
See your Windows documentation for information about modifying icon
properties.
MORE INFORMATION
Modification Type: | Major | Last Reviewed: | 1/14/2000 |
---|
Keywords: | KB125521 |
---|
|