ACC2: Error Message "Couldn't Open SYSTEM.MDA" (123589)
The information in this article applies to:
This article was previously published under Q123589
Moderate: Requires basic macro, coding, and interoperability skills.
SYMPTOMS
When you start Microsoft Access, you may receive either of the following
error messages:
- Couldn't open SYSTEM.MDA
-or-
- <Database> is corrupted or is not a database file. Attempt to repair?
CAUSE
The Microsoft Jet database engine version 2.0 may erroneously leave an
internal database flag set that in some cases results in one of the error
messages stated above.
RESOLUTION
To reset the internal database flag, have all users log out of the database
and then run the repair utility. (To run the repair utility, choose Repair
from the File menu.) If you receive the "Couldn't open SYSTEM.MDA" error
message, all users should quit Microsoft Access. When the first user logs
back in, the SYSTEM.MDA file is repaired automatically. No data will be
lost as a result of the internal database flag being set erroneously.
STATUS
This problem no longer occurs with the Microsoft Jet database engine
version 2.5, which is available with the Microsoft Access version 2.0
Service Pack. For information about how to obtain the Service Pack, please
see the following article in the Microsoft Knowledge Base:
122927 WX1124: Microsoft Access Version 2.0 Service Pack
Modification Type: | Major | Last Reviewed: | 7/5/2002 |
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Keywords: | kbbug kbusage KB123589 |
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