WFW 3.11 Clients Hang Accessing Windows NT Server (123029)
The information in this article applies to:
- Microsoft Windows NT Server 3.1
- Microsoft Windows NT Workstation 3.1
- Microsoft Windows NT Advanced Server 3.1
- Microsoft Windows NT Workstation 3.5
- Microsoft Windows NT Server 3.5
- Microsoft Windows for Workgroups
This article was previously published under Q123029 SYMPTOMS
Windows for Workgroups version 3.11 hangs when you run a database
application that is using a shared file on a Windows NT server.
CAUSE
This problem involves oplock, byte-range lock, and lock-&-close server
message block (SMB) protocols. The behavior that causes this problem is as
follows:
- CLIENT1 has a file open with an exclusive oplock and is using the file.
- CLIENT2 tries to open the file.
- SERVER sends an oplock break request to CLIENT1.
- CLIENT1 (MIDx) sends and oplock broken (locktype = x'02'). Even though
locktype = x'02', the SMB specifies to lock range 0-EOF.
- CLIENT1 (MIDy) sends an unlock&close request specifying 0-EOF.
- SERVER (MIDy) responds with "no such lock" error. SERVER did not close
the file because the unlock request failed.
- SERVER (**MIDx) responds indicating successful lock on range 0-EOF.
- CLIENT1 thinks file is unlocked and closed.
- SERVER still has file opened with locked range 0-EOF.
- Other clients will get lock error when they try to access the file.
A deadlock condition occurs since CLIENT1 thinks that the file handle was
closed and therefore will never unlock the byte range.
RESOLUTION
A workaround for this problem is to turning off opportunistic locking at
the file server.
STATUS
Microsoft has confirmed this to be a problem in Windows 3.11. A fix to this
problem is in development, but has not been regression-tested and may be
destabilizing in production environments. Microsoft does not recommend
implementing this fix at this time. Contact Microsoft Product Support
Services for more information on the availability of this fix.
Modification Type: | Major | Last Reviewed: | 12/6/2003 |
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Keywords: | KB123029 |
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