Using Null Modem for RAS with Third-Party PPP Clients (122318)



The information in this article applies to:

  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 4.0

This article was previously published under Q122318

SYMPTOMS

When you attach a third-party Point-to-Point Protocol (PPP) client to a Remote Access Service (RAS) server via a null modem cable, the RAS server port status reports a hardware failure and no connection is made.

CAUSE

This problem occurs due to the null modem scripts in the MODEM.INF file being specifically written for Windows NT computers only.

RESOLUTION

To correct this problem, you can modify the Null Modem entry in the MODEM.INF file for the Windows NT RAS server and the INI extension file for the third-party PPP client.

NOTE: If you are using Modem.inf with Microsoft Windows NT version 4.0, see the following article in the Microsoft knowledge base:

ARTICLE-ID: 150808
TITLE : Disabling Support for Unimodem Modems in Remote Access



Server Side

Change the Null Modem entry in the MODEM.INF file to the following:

   CALLBACK_TIME=10
   DEFAULTOFF=compression
   MAXCARRIERBPS=19200
   MAXCONNECTBPS=19200

   COMMAND_INIT=
   NoResponse

   COMMAND_LISTEN=
   CONNECT=$
   CONNECT=<h00>CLIENT
   COMMAND_LISTEN=
   NoResponse

   COMMAND_DIAL=CLIENT
   CONNECT=SERVER
				


Client Side

For the client side, you want to send a "$" (without quotation marks) to signify a CONNECT. For example, the Chameleon product from NetManage, Inc., uses a SLIP.INI file to send scripts. In the section for Windows NT, change the following lines:

   "script=-n" to "script=-n $$ -n" (without quotes)
				


The Chameleon product discussed here is manufactured by NetManage, Inc., a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding this product's performance or reliability.

Modification Type:MajorLast Reviewed:5/6/2003
Keywords:kb3rdparty KB122318