Office: Error Message Occurs When Using Extract Utility (122209)
The information in this article applies to:
- Microsoft Office for Windows 4.2c
- Microsoft Office for Windows 4.3c
- Microsoft Office for Windows 95
- Microsoft Office for Windows 95 7.0b
This article was previously published under Q122209 SYMPTOMS
When you use the Extract utility to manually extract files for one of the
applications listed above, you may receive an error message similar to one
of the following:
Write protect error writing drive A
Abort, Retry, Fail?
ERROR: Not enough space for temporary file \esf2 while decompressing
excel1.cab:
524288 bytes needed
CAUSE
This problem occurs under the following conditions:
- The current directory is low on available disk space
-or-
- The current directory is write protected
-or-
- The current directory is on a network drive, and you do not have the
privileges required to write to this drive.
-AND-
- The environment variable TMP is not set (Office 4.x only).
This behavior occurs because the Extract utility, EXTRACT.EXE, uses the
environment variable TMP to determine where to write a temporary file while
extracting files from the application's cabinet files. If this variable is
not set, the Extract utility attempts to write the temporary file to the
root directory of the current drive. If the current drive is read-only,
(such as a network drive that you do not have privileges to write to, or a
floppy disk drive that is write protected) or does not have enough
available disk space for the temporary file, you receive an error message
similar to the messages listed above and the file is not expanded.
When installing Microsoft Office for Windows 95, version 7.x, it is not
necessary to set the TMP variable.
Note: The TMP environment variable should be set in addition to the TEMP
environment variable.
STATUS
Microsoft has confirmed this to be a problem with the EXTRACT.EXE utility
that ships with the Microsoft products listed at the beginning of this
article. We are researching this problem and will post new information here
in the Microsoft Knowledge Base as it becomes available.
WORKAROUND
To avoid receiving these error messages when you use the Extract utility,
do any of the following:
- Change the current directory to a read-write drive that has plenty of
available disk space, before you use the Extract utility. Note that the
Extract utility allows you to use a full path to specify both the
location of the files that you are extracting, and where to place the
extracted files.
-or-
- Set the TMP environment variable to a valid read-write drive. You can do
this by adding a command similar to the following to the AUTOEXEC.BAT
file:
For additional information, please see the following article(s) in the
Microsoft Knowledge Base:
120006 XL: How to Copy Files from Cabinets on DMF-Formatted Disks
Modification Type: | Minor | Last Reviewed: | 8/16/2005 |
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Keywords: | kbsetup KB122209 |
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