PRB: Starting a Service Returns "Logon Failure" Error (120556)
The information in this article applies to:
- Microsoft Win32 Application Programming Interface (API), when used with:
- the operating system: Microsoft Windows NT 3.51
- the operating system: Microsoft Windows NT 4.0
- the operating system: Microsoft Windows 2000
- the operating system: Microsoft Windows XP
This article was previously published under Q120556 SYMPTOMS
Starting a service from either the Service Control Manager or from the
StartService API may return error 1069,
ERROR_SERVICE_LOGON_FAILED.
CAUSE
This error occurs if the service was started from an account that does not
have the "Log on a service" right.
RESOLUTION
An account can be granted the "Log on a service" right programmatically
or through the User Manager Application. Both of these methods are
described below.
User Manager Application Method- In the User Manager application, choose User Rights from the Policies
menu.
- In the User Rights dialog box, select the "Show Advanced User Rights"
check box.
- Choose "Log on a service," in the "Right" scroll box.
- Choose the Add button to grant your account the "Log on a service"
right.
Programmatically Method
An account can also be granted the user right programmatically through the
Local Security Authority (LSA) API calls. For more information on this
topic, please see the following article in the Microsoft Knowledge Base:
132958
How to Manage User Privileges Programmatically in Windows NT
Modification Type: | Major | Last Reviewed: | 4/12/2004 |
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Keywords: | kbAPI kbKernBase kbprb kbSecurity kbService KB120556 |
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