Running Applications That Require Windows 3.1 or Later (120174)



The information in this article applies to:

  • Microsoft Windows 95
  • Microsoft Windows 98

This article was previously published under Q120174

SYMPTOMS

When you install or run a program, you receive an error message stating that the program requires Windows version 3.1 or later.

CAUSE

When you start a program, the program checks the Windows version number to determine whether it can run safely. Some programs check this version number incorrectly and return an error message.

RESOLUTION

You may be able to work around this problem using one of the following methods:
  • Try the following steps to run the program in Windows 95:

    1. Click the Start button, click Run, type "mkcompat" (without quotation marks) in the Open box, then click OK.
    2. On the File menu, click Choose Program.
    3. Select the program's executable file so that it appears in the File Name box, then click the Open button.
    4. Click the Lie About Window's Version Number check box to select it.
    5. On the File menu, click Save.
    6. Quit the Make Compatible tool.
    7. Try running the program again.
    NOTE: If the executable filename is INSTALL or SETUP, perform these steps again and remove the check mark in step 4 after you have successfully installed the program. The presence of this setting can cause other installation programs to fail.
  • Contact the program's manufacturer to determine if an upgrade is available.
  • Try the following steps to manually update the Win.ini file so that the program will run in Windows 95:

    1. Start Windows Explorer.
    2. Open the folder containing the executable file you want to run.
    3. Use the right mouse button to click the executable file, then click Quick View on the menu that appears. Note the module name in the Quick View window.
    4. Use any text editor (such as WordPad) to open the Win.ini file.
    5. In the [Compatibility] section of the file, add the following line
               <ModuleName>=0x00200000
          
      								
      where <ModuleName> is the name you noted in step 3.
    6. Save and close the Win.ini file.
    7. Try running the program again.

      NOTE: If the module name is INSTALL or SETUP, restore the original value to the INSTALL= line. The default value is INSTALL=0x00400000.

      If these steps do not work, you may want to contact the program's manufacturer to make sure you are using the correct module name, or to determine if there are other workarounds.

STATUS

This situation is most likely caused by design changes in Windows. Microsoft has confirmed that it is not caused by a problem in Windows. For more information about resolving this issue, contact the third-party software manufacturer.

MORE INFORMATION

The following programs are known to check the Windows version number incorrectly. The steps in the "Resolution" section of this article may work with these programs:

Outpost 1.0, 1.0a, and 1.0b by Sierra On-line

When you install Outpost, you receive the following error message:
   Outpost requires Windows 3.1, or higher
				

To install Outpost in Windows 95, use one of the following methods:
  • Use the Make Compatible tool and click the Lie About Window's Version Number check box for Install.exe.

    Remember to remove this setting after you install Outpost.

    -or-
  • The module name for Outpost is INSTALL. Add the following statement to the [Compatibility] section of the WIN.INI file:
          INSTALL=0x00200000
      
    						
    Remember to restore this statement's value after you install Outpost.

Passport 1.2 by Advantis

When you run Passport, you receive the following error message:
Passport requires Windows 3.1, or higher

To run Passport in Windows 95, use one of the following methods:
  • Use the Make Compatible tool and click the Lie About Window's Version Number check box for Passport's executable file.

    -or-
  • Determine the module name and then add the following statement to the Win.ini file:
          <ModuleName>=0x00200000
     
    					
The third-party products discussed in this article are manufactured by vendors independent of Microsoft; we make no warranty, implied or otherwise, regarding these products' performance or reliability.

Modification Type:MinorLast Reviewed:12/16/2004
Keywords:kb3rdparty kbAppCompatibility kberrmsg kbprb KB120174