ACC: Duplicate Records in dBASE IV File Missing (120130)



The information in this article applies to:

  • Microsoft Access 2.0
  • Microsoft Access for Windows 95 7.0
  • Microsoft Access 97

This article was previously published under Q120130
Moderate: Requires basic macro, coding, and interoperability skills.

SYMPTOMS

If you link (attach) a dBASE IV file without selecting an index file, some of the data in the dBASE IV file may appear to be missing when you open the linked table.

CAUSE

You may be using a dBASE IV index file whose "Display First Duplicate Key Only" setting is turned on. This dBASE IV setting causes records with duplicate primary key values to be hidden.

RESOLUTION

Make sure to specify an index in dBASE IV that displays all records, and make sure to select the appropriate index file when you link a dBASE IV file in Microsoft Access.

If the index file and all records are selected correctly, then look for more information on the ISAM settings in the following article in the Microsoft Knowledge Base:

95388 ACC: dBASE SET DELETED Characteristic in Microsoft Access

MORE INFORMATION

When you link a dBASE IV file, you are prompted to select an index file. If you do not select an index file, Microsoft Access selects one for you. When Microsoft Access selects an index file for you, it first looks for an index file with the same name as the data file you are linking. If it cannot find such a file, Microsoft Access then looks for the most recently created or changed index file.

When you let Microsoft Access select the index file for you, you are taking a chance that Microsoft Access will select an index file whose "Display First Duplicate Key Only" setting is turned on. If Microsoft Access selects such an index file, any record in the data file with a duplicate primary key value will be hidden automatically.

Once a primary index file is selected, the only way to use a different index file is to delete the link in Microsoft Access, and then link the table again.

dBASE IV is manufactured by Borland International, Inc., a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding this product's performance or reliability.

REFERENCES

For more information about attaching dBASE IV files, search the Help Index for "dBASE files," or ask the Microsoft Access 97 Office Assistant.

Modification Type:MajorLast Reviewed:5/6/2003
Keywords:kbinterop kbprb KB120130