ACC2: Errors After Reinstalling MS Access to Workstation (120058)
The information in this article applies to:
This article was previously published under Q120058 SYMPTOMS
Advanced: Requires expert coding, interoperability, and multiuser skills.
When you reinstall Microsoft Access to a workstation and then start
Microsoft Access, you receive an error message similar to:
Couldn't find file 'G:\ACCESS\SYSTEM.MDA'
If you modify the MSACC20.INI file so that the SystemDB line in the
[Options] section of the file points to the correct path for the SYSTEM.MDA
file and then start Microsoft Access, you receive the following error
message repeatedly while the Add-ins are being loaded:
Tried to load module with duplicate procedure definition:
doc_CleanObjTables
CAUSE
When you reinstall Microsoft Access to the workstation, incorrect settings
are written to the MSACC20.INI file. For example, the line
SystemDB=G:\ACCESS\WORKDIR\SYSTEM.MDA
is changed to:
SystemDB=G:\ACCESS\SYSTEM.MDA
Note that the WORKDIR subdirectory is missing from the path for the
SYSTEM.MDA file after the reinstallation.
The [Libraries] section of the file might look like the following example
before the reinstallation:
[Libraries]
G:\ACCESS\WORKDIR\wzLib.mda=rw
G:\ACCESS\WORKDIR\wzTable.mda=rw
G:\ACCESS\WORKDIR\wzQuery.mda=rw
G:\ACCESS\WORKDIR\wzFrmRpt.mda=rw
G:\ACCESS\WORKDIR\wzBldr.mda=rw
After the reinstallation, the [Libraries] section might look like:
[Libraries]
G:\ACCESS\WORKDIR\wzLib.mda=rw
G:\ACCESS\WORKDIR\wzTable.mda=rw
G:\ACCESS\WORKDIR\wzQuery.mda=rw
G:\ACCESS\WORKDIR\wzFrmRpt.mda=rw
G:\ACCESS\WORKDIR\wzBldr.mda=rw
wzLib.mda=rw
wzTable.mda=rw
wzQuery.mda=rw
wzFrmFpt.mda=rw
wzBldr.mda=rw
Note that duplicate entries that do not have a path are listed in the
[Libraries] section after the reinstallation.
RESOLUTION
Make the following changes to the MSACC20.INI file:
- Modify the SystemDB line in the [Options] section to point to the
correct path for the SYSTEM.MDA file.
- Delete the entries in the [Libraries] section that do not specify a
full path.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Access version
2.0. We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.
REFERENCES
For more information about settings in the MSACC20.INI file, search for
"MSACC20.INI," and then "Customizing MSACC20.INI Settings" using the
Microsoft Access Help menu.
Modification Type: | Major | Last Reviewed: | 11/6/2000 |
---|
Keywords: | kbbug kberrmsg kbsetup KB120058 |
---|
|