ACC: ORACLE Tools Do Not Recognize Exported Microsoft Access Tables (119135)
The information in this article applies to:
- Microsoft Access 2.0
- Microsoft Access for Windows 95 7.0
This article was previously published under Q119135
Moderate: Requires basic macro, coding, and interoperability skills.
SYMPTOMS
ORACLE tools do not recognize Microsoft Access tables that you have
exported.
CAUSE
ORACLE tools reference all database objects (such as table names) in
uppercase letters. If you export a Microsoft Access table whose name
contains mixed uppercase and lowercase letters, ORACLE tools such as
SQL*Net and SQL*Plus will not recognize the table.
RESOLUTION
To use the ORACLE tools on an exported Microsoft table whose name contains
mixed uppercase and lowercase letters, place double quotations marks around
the table name (for example, SELECT * FROM "Customers").
Another workaround to this behavior is to rename your tables using only
uppercase letters and then export them again.
STATUS
This behavior is by design.
MORE INFORMATION
Microsoft Access sends information to and retrieves information from ORACLE
as literals, placing quotation marks around table and field names. This
causes ORACLE to store Microsoft Access table and field names as literals,
retaining the mixed uppercase and lowercase letters. ORACLE only recognizes
names that contain only uppercase letters.
The third-party products discussed here are manufactured by Oracle
Corporation, a vendor independent of Microsoft; we make no warranty,
implied or otherwise, regarding these products' performance or reliability.
Modification Type: | Major | Last Reviewed: | 7/8/2002 |
---|
Keywords: | kb3rdparty kbprb KB119135 |
---|
|