FIX: "Cannot Activate OLE Server"; Graphic Doesn't Print (117586)



The information in this article applies to:

  • Microsoft FoxPro for Windows 2.5
  • Microsoft FoxPro for Windows 2.5a
  • Microsoft FoxPro for Windows 2.5b
  • Microsoft FoxPro for Windows 2.6
  • Microsoft FoxPro for Windows 2.6a

This article was previously published under Q117586

SYMPTOMS

The Report Writer will not print a general field that contains a graphic pasted from the Clipboard.

CAUSE

Since the Report Writer is looking for an OLE server to print the graphic contained in the general field and the Clipboard is not an OLE server, the area where the graphic should have been printed will be blank.

RESOLUTION

Paste the graphic into Paintbrush and save it as a bitmap (.BMP) file. Reference the .BMP file in the general field of the data file. The Report Writer will use Paintbrush as the OLE server.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article. This problem was corrected in Visual FoxPro 3.0 for Windows.

MORE INFORMATION

This behavior usually occurs when the PRINT SCREEN key or the ALT+PRINT SCREEN key combination is used to create screen captures.

Steps to Reproduce Behavior

  1. Capture a screen by pressing PRINT SCREEN or ALT+PRINT SCREEN.
  2. Open a general field in one of the data files.
  3. Paste the screen capture in the general field.
  4. Create a report that prints the general field.
  5. From the Report menu, choose Page Preview.

    The screen capture will be displayed.
  6. From the Command window, issue REPORT FORM <formname> TO PRINTER.
Nothing is printed in the place where the screen capture should be located. Furthermore, if you double-click the screen capture displayed in the data file's general field, you will receive the following error message:
Cannot Activate OLE Server

Modification Type:MajorLast Reviewed:12/3/2003
Keywords:kbbug kberrmsg kbfix KB117586