PC Ext: MTA Not Report LAN Man User-Level Security Problems (117152)



The information in this article applies to:

  • Microsoft Mail for PC Networks 2.1
  • Microsoft Mail for PC Networks 3.0
  • Microsoft Mail for PC Networks 3.2
  • Microsoft Mail for PC Networks 3.5

This article was previously published under Q117152

SYMPTOMS

The External Mail (EXTERNAL.EXE) message transfer agent (MTA) included with Microsoft Mail for PC Networks or the MMTA for OS/2 version that ships separately, may fail to report or log that it is unable to read or write to a destination postoffice. This problem can occur when the postoffice is installed on a Microsoft LAN Manager version 2.x (or compatible) network drive accessed by a user-level account granted with read-only access privileges.

Another indication of a read-only access problem is in delivering mail. When mail is to be delivered to a postoffice with read-only access, the following message appears on the External Mail program screen and in the session log (if logging is enabled):
Unable to Generate file prefix due to critical error.
Mail transfer failed.
After three attempts, the following entry is written to the system log:
[005] Mail retry count exceeded sending to:

<network> /<post office>

CAUSE

When the log (-L) switch is used on the command line of an MTA configured to work with postoffices hosted on LAN Manager (or compatible) servers, the External Mail program may not detect read-only access of the MTA account, thus preventing mail from being delivered. If the log is to be written to the drive with read-only access, the External Mail program will fail to start and will display the message "Error writing to the log file." If the log is written to a drive or postoffice where read/write access is available, no message appears.

Mail queued up to be sent from a postoffice with read-only access will not be delivered. The External Mail program cannot transfer mail from the outbound queue because it cannot open an .OLK file with write/exclusive access. Mail will remain in the queues and will effectively be ignored. The External Mail program cannot tell whether it does not have network rights or whether another External Mail program has the .OLK file locked.

Another cause for the above error can also be due to the MASTER.GLB located in the \MAILDATA\GLB directory being locked open. (in the case of the MTA) or not marked as shareable (in the case of the Multitasking MTA).

RESOLUTION

The resolution is to ensure the file in not locked open, or set to sharable. Use RCONSOLE in a Novell environment, or check Control Panel, Services on a Windows NT-based network to check the integrity of this file.

When you use the MMTA, use utilities specific to the Network Operating System to verify the file.

MORE INFORMATION

For additional information, please see Chapter 2 of the Mail 3.2 "Administrator's Guide" and the Appendix G of the Mail 3.2 "Administrator's Guide."

Modification Type:MajorLast Reviewed:11/4/1999
Keywords:KB117152