ACC: "Couldn't Lock File; SHARE.EXE Hasn't Been Loaded" Error (116387)
The information in this article applies to:
- Microsoft Access 1.0
- Microsoft Access 1.1
- Microsoft Access 2.0
- Microsoft Access for Windows 95 7.0
This article was previously published under Q116387
Moderate: Requires basic macro, coding, and interoperability skills.
SYMPTOMS
When you try to open a Microsoft Access database, you receive the following
error message even though you are running SHARE.EXE or VSHARE.386:
Couldn't lock file; SHARE.EXE hasn't been loaded.
CAUSE
This error can occur if Microsoft Access cannot perform record locking on
the database's corresponding .ldb file. If, for example, the .ldb file is
set to Read-Only, either on your local hard disk or on a network server,
this problem occurs.
With an administrative network setup (setup /a), the .ldb files under
the Workdir folder are not created until the first user opens Microsoft
Access. This error can also occur if the first user does not have Create
rights.
RESOLUTION
Set the .ldb file to Read-Write, not Read-Only. Also give Read, Write, and
Create rights to the Workdir folder for each user that is using Microsoft
Access.
REFERENCES
For more information about .ldb files, search for "LDB files" then "Locking
Information Files (Common Questions)" using the Microsoft Access Help menu.
Modification Type: | Major | Last Reviewed: | 5/6/2003 |
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Keywords: | kbenv kberrmsg kbprb KB116387 |
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