ACC2: Error "Setup Cannot Create SYSTEM.MDA File (-1809)" (115066)



The information in this article applies to:

  • Microsoft Access 2.0

This article was previously published under Q115066
Novice: Requires knowledge of the user interface on single-user computers.

SYMPTOMS

When you run Microsoft Access Setup, after the last disk has loaded, Setup has updated your system, and the Program Manager icons have been created, you receive the following error message:
Setup couldn't create a SYSTEM.MDA file. After Setup is completed, reboot your computer, then run the Workgroup Administrator before you run this application. (-1809)

CAUSE

This error occurs when a file-sharing utility has not been loaded prior to running Setup.

Setup uses a program called the Workgroup Administrator (WRKGADM.EXE) to create the SYSTEM.MDA file. The Workgroup Administrator requires a file- sharing utility such as SHARE.EXE or VSHARE.386 (the virtual device driver file-sharing utility used in Windows 386 enhanced mode) to work correctly.

RESOLUTION

To solve this problem, follow these steps:
  1. After Setup completes, quit Microsoft Windows.
  2. If you run Windows version 3.1 in standard mode, make sure that SHARE.EXE is loaded in your AUTOEXEC.BAT or CONFIG.SYS file, or load it at the MS-DOS command prompt.
  3. If you run Windows version 3.1 or Windows for Workgroups version 3.1x in 386 enhanced mode, make sure that VSHARE.386 is loaded in the [386Enh] section of your SYSTEM.INI file.
  4. Start Microsoft Windows.
  5. Start the Workgroup Administrator by double-clicking the MS Access Workgroup Administrator icon, and then create a new SYSTEM.MDA file.
  6. Start Microsoft Access.
Microsoft Access must have a valid SYSTEM.MDA file to work correctly. If you try to start Microsoft Access before you create the SYSTEM.MDA file, you will receive the error message:
Couldn't find file 'C:\ACCESS\system.mda'.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Access version 2.0. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Modification Type:MajorLast Reviewed:6/25/2002
Keywords:kbbug kberrmsg kbsetup KB115066