Sys1719 Error After Upgrading to IBM OS/2 2.1.1 (114722)



The information in this article applies to:

  • Microsoft LAN Manager 2.2a
  • Microsoft LAN Manager 2.2b

This article was previously published under Q114722

SYMPTOMS

If you upgrade from IBM OS/2 2.1 workstation to OS/2 2.1.1 using IBM's service pack XR6200 and try to reboot the workstation you receive:
SYS1719 error, invalid file system or device driver

CAUSE

Microsoft Product Support Services recommends that you reinstall the Microsoft LAN Manager client software after upgrading to IBM OS/2 2.1. When this is done, the Microsoft LAN Manager 2.2a Client or LAN Manager 2.2b Upgrade installs the NETWKSTA.SYS driver intended for OS/2 1.3 clients instead of the version for OS/2 2.1 or OS/2 2.1.1.

RESOLUTION

Use this procedure to get the correct driver on the client:

  1. Use DECOMP to decompress the NETWKSTA.SY$ file from the WKSTA20 subdirectory (on Disk #1 of the 2.2b patch, or Disk #2 (LMOS2WRKST1) of the 2.2a client software) and copy it into c:\lanman\netprog, replacing the NETWKSTA.SYS that is already there. Here is the command:
         Decomp  A:\wksta20\netwksta.sy$ c:\lanman\netprog\netwksta.sys
    						
  2. Change the OS2VER file located in the root directory:
         From:  20=netwksta.200     To:  20=netwksta.sys
    						
    Before you can edit the file, you must remove its attributes. Make sure you add them back on before re-booting the workstation.

    • to remove: attrib -s -r -h OS2VER
    • to add them back on: attrib +s +r +h OS2VER

STATUS

Microsoft has confirmed this to be a problem in LAN Manager 2.2a and 2.2b and will post new information here in the Microsoft Knowledge Base as it becomes available.

Modification Type:MajorLast Reviewed:9/30/2003
Keywords:KB114722