Unable to Upgrade Service Pack 2 On Magneto Optical Drives (114244)



The information in this article applies to:

  • Microsoft Windows NT Server 3.1
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Advanced Server 3.1

This article was previously published under Q114244

SYMPTOMS

When upgrading Windows NT version 3.1 to Service Pack 2 on a Magneto Optical drive or any removable drive, the Update program reports there is not enough space available when there is space left on the disk.

CAUSE

The Win32 API that determines drive type informs the Update program that the drive is DRIVE_REMOVABLE; the Update program considers it to be a floppy, so the free space check ends up incorrect.

RESOLUTION

No resolution is available at this time.

STATUS

Microsoft has confirmed this to be a problem in Windows NT and Windows NT Advanced Server version 3.1. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.


Modification Type:MajorLast Reviewed:11/20/2003
Keywords:kbother KB114244