AT Command Fails to Run Some Applications (113073)



The information in this article applies to:

  • Microsoft Windows NT Server 3.1
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Advanced Server 3.1

This article was previously published under Q113073

SYMPTOMS

If you have either a batch file or a command file that contains OS/2 commands and uses the Schedule service to run, OS/2 commands in the file are not executed.

This applies to both the AT.EXE scheduler that comes with Windows NT and the WINAT.EXE scheduler that comes with the Windows NT Resource Kit.

CAUSE

By default, the schedule service runs under the System account. If you change the schedule service to use a different logon account, OS/2 commands become operational, but Win32 commands do not function properly. Note that this behavior only applies to batch or command files being scheduled, and does not apply to interactive usage.

RESOLUTION

You can change the account that the schedule service uses by doing the following:

  1. From the Control Panel window, choose the Services icon.
  2. Select the Schedule service.
  3. Choose the Startup button.
  4. Change the Log On As account from System to the account of your choice.
  5. Choose OK to keep your selection.
At this time, there is no workaround to run both types of commands in a single, scheduled batch file or command file.

STATUS

Microsoft has confirmed this to be a problem in Windows NT and Windows NT Advanced Server version 3.1. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Modification Type:MajorLast Reviewed:11/20/2003
Keywords:KB113073