Application Log Full Dialog Box Appears Instead of Overwriting (108070)



The information in this article applies to:

  • Microsoft Windows NT Server 3.1
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Advanced Server 3.1

This article was previously published under Q108070

SYMPTOMS

An Application Log Full dialog box incorrectly appears on the Application Log screen of Event Viewer in the following situation:

  1. You set Event Log Wrapping to Overwrite Events As Needed in the Event Log Settings dialog box.
  2. The Application Log completely fills with events.
  3. In the Control Panel window, choose the Date/Time icon, and then set the time back a few minutes.
  4. Immediately log more events to the Application Log.
The Application Log Full dialog box appears. This should not happen because you have set the Application Log to Overwrite Events As Needed.

CAUSE

The Application Log Full dialog box incorrectly appears in this situation because Event Log does not continue to overwrite log files based on the time difference.

STATUS

Microsoft has confirmed this to be a problem in Windows NT and Windows NT Advanced Server version 3.1. This problem has been corrected in Windows NT Workstation and Windows NT Server version 3.5. This problem has also been corrected in the latest U.S. Service Pack for Windows NT and Windows NT Advanced Server version 3.1. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K
				

Modification Type:MajorLast Reviewed:11/20/2003
Keywords:KB108070